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1 Description
HP CloudSystem Matrix is designed to simplify the deployment of infrastructure, applications, and
cloud services by delivering IT capacity through pools of readily deployed resources. The goal of
the Matrix Operating Environment (Matrix OE) is to accelerate provisioning, optimize IT capacity
across physical and virtual environments, and to ensure predictable delivery and service levels.
CloudSystem Matrix is built on the modular, standards-based HP BladeSystem and its proven
innovations, including Virtual Connect (VC) and the Matrix OE. With its open, extensible approach,
CloudSystem Matrix runs any application workload and provisions the entire infrastructure, including
servers, storage, and networking, within minutes. CloudSystem Matrix is optimized for HP ProLiant
and HP Integrity server blades, HP storage, and HP networking but also supports third-party x86
servers, networking, and storage. CloudSystem Matrix is deeply integrated with virtualization
technologies such as VMware and Microsoft, through the integration of virtual machine (VM)
template libraries.

Matrix versioning
HP CloudSystem Matrix versions are indicated by major.minor.update.revision. For example,
version 7.4.0.1 is Matrix 7.4 Revision 1. Revisions are only for firmware, driver, and/or agent
changes to the CloudSystem Matrix recipe.

Update recommendation
• All upgrades to HP CloudSystem Matrix 7.5 from versions to CloudSystem Matrix 7.4 Update

1 and prior must be performed by HP Technology Services.

Supersedes
The 7.5 version supersedes the 7.4.x.x released versions.

Operating systems and devices
Supported operating systems and devices are listed in the HP CloudSystem Matrix 7.5 Compatibility
Chart available at:
www.hp.com/go/matrixcompatibility
Additional information is included in the HP Insight Management 7.5 Support Matrix available at:
www.hp.com/go/matrixoe/docs

Enhancements
The HP CloudSystem Matrix 7.5 solution contains a requirement for a specific set of firmware
versions for most of the important hardware components in the solution. The HP CloudSystem Matrix
7.5 Compatibility Chart v7.5 specifies the supported hardware components and defines the
required firmware versions.

Software enhancements
Some of the software enhancements to Insight Management 7.5 update include:
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New operating systems, databases, and hypervisors
Adds the following:

• Red Hat Enterprise Linux (RHEL) 7.1

Other software enhancements
Adds the following:

• Google Chrome 43

• Mozilla Firefox 38 ESR

• Insight Management to version 7.5

• HP SUM Integrity CloudSystem Matrix bundle to version 7.5

• HP Service Pack for ProLiant (SPP) 2015.0.6.0

• Support for Co-existence of Microsoft Hyper-V Replica

• Support of VMware ESXi Customization of Machine Object OU

• Support of VMware ESXi and Microsoft Hyper-V Customization of Run Once Command

• Support of Microsoft Hyper-V Network Virtualization using NVGRE

◦ IO services and logical servers using NVGRE can be DR protected with Matrix recovery
management

Matrix recovery management enhancements

• Support for physical IO services: MRM can now DR protect physical IO services, and provide
information in UI for the newly imported physical IO services or physical logical servers that
require manual storage configuration after MRM import. MRM alerts the user about manual
storage configuration requirement with new status in import jobs, enhanced job log information,
new status in Recovery Groups tab, and prevents disabling Maintenance Mode for groups
that have members that still require storage configuration.

• Support for automatic storage configuration with HP Storage Provisioning Manager: Provides
support for automatic configuration of storage during logical server creation and/or
synchronization during the import process for logical servers and IO services that uses new
HP Storage Provisioning Manager templates with Remote Copy requirements.

• Support for creation and synchronization of peer logical servers on the remote site: MRM
import can now create peer logical servers, and synchronize changes (memory, CPU, network
and storage) done to logical server in primary site to the recovery site. The new drsync
command line is available also to synchronize servers between sites without the need to failover
storage.

• Support for on-line configuration for the remote site through the import process: There is no
need to deactivate the primary site prior to import MRM Recovery Groups with IO physical
services or with logical server both physical and virtual.

• Matrix recovery management messages that were being logged in mxdomainmgr.0.log
are now being redirected to logs\lsdt_web.log in the Matrix recovery management
installation directory

• Matrix recovery management now supports Microsoft Hyper-V logical switches

• Matrix recovery management now supports ESXi vNetwork Distributed Switch (dvSwitch, vDS)
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• Matrix recovery management now supports NT LAN Manager 2 (NTLMv2) Authentication

• Minor GUI enhancements:

Added log file guidance in error and warning messages◦
◦ Displays the site name instead of the default text Local Site

Fixes
The objectives of this release are to support the latest HP hardware platforms, support the latest
revisions of already supported operating systems and hypervisors, add new functionality, and fix
software issues.
Software updates improve performance in large scale environments.

Prerequisites
• Hardware, firmware, and software requirements for this release are listed in the HP

CloudSystem Matrix 75 Compatibility Chart .
• Installation and upgrade prerequisites are documented here.
CloudSystem Matrix documentation is available at:
www.hp.com/go/matrixoe/
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2 Installation and configuration
Install HP CloudSystem Matrix v7.5

Before upgrading the firmware
Before upgrading the firmware:

• Upgrade or migrate the CMS Insight Management Software, if applicable.

• Upgrade the CMS environment firmware.

• Proceed through the CloudSystem Matrix upgrade process for each managed system.
Upgrading the CMS first results in a more predictable process and less variability than other
processes. If the CMS is hosted on a server blade, HP recommends starting the firmware upgrade
process with the enclosure containing the CMS. Start with the firmware on the CMS server blade
itself, followed by the firmware on the other server blades in the same enclosure, and then the OA
and VC infrastructure firmware on the enclosure.

IMPORTANT: Before applying the SPP or Integrity bundle, all physically managed servers and
hypervisor hosts (Linux, Windows, or ESXi) must conform to the current operating system versions
listed in the HP CloudSystem Matrix Compatibility Chart.

CMS software installation
The HP Insight Management Incremental Update Installer utility is shipped in the ISO file. The utility
evaluates the components currently installed on your server and automatically installs all software
updates that are missing.

Installation prerequisites
1. Be sure that the Central Management Server (CMS) meets the following criteria:

a. HP Insight Management 7.5 is installed
b. HP Insight Management services are up and running

2. Obtain the Insight Management 7.5 ISO DVD images from the following sources:
• HP Insight Management downloads web site: http://www.hp.com/go/insightupdates

• HP Software Depot: http://software.hp.com/portal/swdepot/displayProductInfo.do?
3. Use an ISO mounting utility to mount the ISO image or extract the ISO structure to a folder.

IMPORTANT: If extracting the ISO image to a folder, extract the entire contents of the ISO
and leave the file and directory structure intact.

4. Close or disable virus scanning software before starting the update. Virus scanning software
might slow down the update process or cause a component update to fail.
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5. Before upgrading, back up the following customized files:
C:\Program Files\HP\Matrix infrastructure Orchestration\conf\
blade_models.properties

C:\Program Files\HP\Virtual Server Environment\conf\esa.properties

C:\Program Files\HP\Virtual Server Environment\conf\lsa\
hp_lsa_service.conf

C:\Program Files\HP\Virtual Server Environment\conf\lsa\
lsa.properties

C:\Program Files\HP\Virtual Server Environment\conf\lsa\
lsaclient.properties

C:\Program Files\HP\Virtual Server Environment\conf\lsa\vc\
vcController.properties

C:\Program Files\HP\Virtual Server Environment\conf\lsa\vmm\
vmmController.properties

C:\Program Files\HP\Virtual Server Environment\conf\lsa\storage\
storageController.properties

Installation instructions
1. Sign-in to the CMS as a user with administrator privileges.
2. Navigate to the mounted directory or to the folder where you extracted the ISO image.
3. Click the Setup.exe file in the root of the ISO to start the Insight Management Incremental

Update Installer.
The overview below explains how the Insight Management Incremental Update Installer updates
the software on your CMS.

HP Insight Management Incremental Update Installer overview
1. Verifies that Insight Management 7.5 is installed on the server.
2. Determines if enough disk space is available to install all required updates.
3. Runs a predefined subset of Insight Management Advisor tests in the background to test the

health of the server.
If a major configuration issue is detected, you are presented with the opportunity to manually
run the Insight Management Advisor in order to use the test results to help you resolve the
issue.

4. Detects and presents a list of the software updates that need to be installed based on the
current software configuration. All applicable software updates are installed; you do not have
the option to selectively choose which updates to apply. The Insight Management Incremental
Update Installer notifies you if there are no updates to be installed.
If an Insight Management 7.5 component has already been updated or if a software component
was not installed and is not detected, the related software update does not appear in the list.

5. Prompts you to supply a backup location for the files that will be updated and creates a backup
copy of the files in the location you specify.
If an update is not successful and a rollback is required, the original files are obtained from
this backup location. If a component has its own installer program, its Installer program handles
the rollback. For all other components, the Insight Management Incremental Update Installer
performs the rollback.

6. Prompts you to review the list of updates before clicking Install.
7. Alerts you to turn off any anti-virus software.
8. Stops the HP Systems Insight Manager service and the dependent services.
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9. Creates an update-specific folder and log file in C:\HPIC\logs\IMUpdate73U1 to record
all update operations.

10. Restarts the HP Systems Insight Manager service and verifies that services for all the components
are up and running after the update is complete.

11. Updates the existing registry entry for each component that is successfully updated.
For the Matrix Operating Environment, creates a new 7.5 registry entry without upgrading
the existing 7.4 entry.

12. Generates the UpdateResult.txt file that lists the status of each component that was
updated, which can be viewed from the Complete screen (the last screen of the user interface).

Post-installation instructions
1. Clear your browser's cache before logging in to HP Matrix Operating Environment:

• For Microsoft Internet Explorer, use Tools→Internet Options→Delete Browsing History

• For Mozilla Firefox, use Tools→Clear Recent History

• For Google Chrome, use Settings→History→Clear browsing data
2. Validate that Insight Management 7.5 has been installed.

a. Open the Systems Insight Manager Help→About menu. Verify that each of the following
software versions are listed:
• HP Systems Insight Manager 7.5 (a list of hot fixes are also displayed)

• HP Insight Control server migration 7.5

• HP Matrix Operating Environment 7.5

• HP Matrix infrastructure orchestration 7.5

• HP Matrix Virtual Connect Enterprise Manager 7.5

• HP Insight Control virtual machine management 7.5

• HP Storage Provisioning Manager 2.5
b. Check the following components' home page, or the Add and Remove Programs or

Programs and Features entry in the Windows Control Panel. Verify that each of the
following software versions are listed:
• HP Systems Insight Manager 7.5

• HP Insight Control server migration 7.5

• HP Insight Management Advisor 7.5

• HP Matrix infrastructure orchestration 7.5

• HP Matrix Operating Environment 7.5

• HP System Management Homepage 7.5

• HP Version Control Repository Manager 7.5
Components not listed will be versioned as 7.5.

Results and log files

• The UpdateResult.txt file, which contains update results, is stored in the default location
at C:\Program Files\HP\HP Insight Management incremental update
installer\IMDVD72u2.

• Log files are stored in the C:\HPIC\logs\IMUpdate73U1 folder on the CMS.
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Firmware installation
The instructions in this section pertain to the CloudSystem Matrix 7.5 release only. Installation
instructions for future firmware revisions to this release will be found in the HP CloudSystem Matrix
Firmware, Agents, and Drivers Upgrade Guide.

CloudSystem Matrix firmware update order
In a CloudSystem Matrix environment, update firmware component types in the following order:
1. OA firmware
2. VC firmware
3. Server blade firmware (system ROM, iLO, NIC)

NOTE: The OS-level drivers for the Emulex CNA must be updated prior to applying the SPP.
Even if the OS is not upgraded itself. The OS-level drivers for the Emulex CNA should be installed
as a complete set for all its functions (FCoE/FC/iSCSI/NIC) and must be used only with the
supported firmware versions (i.e. sets of drivers must not be mixed and matched with firmware
versions).

Prerequisites

Perform downloads
Download the components and tools needed to perform an update before proceeding with the
instructions in the next chapter.
1. Download the SPP DVD from www.hp.com/go/spp.
2. Download the CloudSystem Matrix Versioning Tool.

a. Go to www.hp.com/go/matrixcompatibility.
b. Click the tab that corresponds to your version of CloudSystem Matrix.
c. Scroll to the Matrix Versioning Tool section, find the tool, and then click Download.

3. Download the ProLiant MatrixConfig.xml file.
a. Go to www.hp.com/go/matrixcompatibility.
b. Click the tab that corresponds to your version of CloudSystem Matrix.
c. Scroll to the Matrix Versioning Tool section, find the Matrix Configuration (XML), and

then click Download.
4. If there are Integrity BL8x0c i4 or BL8x0c i2 server blades in the environment, download the

HP SUM Integrity CloudSystem Matrix bundle to obtain the latest supported versions of OA
and VC.
The network mezzanine and HBA firmware can also be found on the Integrity bundle. The
BL8x0c i4 embedded SAS controller firmware can be downloaded later.
a. Create a new directory on the CMS to download the update bundle.
b. Go to www.hp.com/go/matrixcompatibility.
c. Scroll to the Matrix Versioning Tool section, find the Matrix Firmware Bundle for HP

Integrity and then click Download.
d. Click Firmware – Bundle.
e. Select the bundle for the Windows-based HP Smart Update Manager and download the

bundle to the CMS.

Additional steps
The following steps must be performed if the HP CloudSystem Matrix Compatibility Chart indicates
that the associated firmware component is not included on the SPP or the HP SUM Integrity bundle.
To download separate firmware components:
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1. If any network adapters need to be updated:
a. From www.hp.com, click Support & Drivers.
b. Click Drivers & Downloads.
c. Enter the product name (for example, NC553m) and click Go.
d. Select the appropriate component.
e. For each operating system type in the CloudSystem Matrix environment:

a. Click the operating system.
b. Click Firmware - Storage Fibre Channel.
c. Select the appropriate adapter firmware and click Download.

2. If any SAS controller needs to be updated:

NOTE: The embedded SAS controller firmware for Integrity BL8x0c i4 server blades is not
included in the bundle if the SAS version currently installed is 5.82 and must be downloaded
separately from http://www.hp.com/go/hpsc. If the version currently installed is 5.84 or
greater, then the embedded SAS controller can be updated using the firmware found on the
bundle.

a. From http://www.hp.com/go/hpsc, under Find an HP product by search, enter the server
blade model (for example, BL860c i4) and click Go.

b. Click View and download all drivers, software and firmware for this product.
c. Select HP-UX 11.31(IA).
d. Click Firmware - Storage Controller.
e. Click Download for the appropriate SAS IO firmware.

3. For VMware customers, download the latest HP custom build .ISO of VMware or the individual
drivers and agents needed to update your existing VMware hosts.
a. Go to http://h18004.www1.hp.com/products/servers/software/vmware/esxi-image.html.
b. Under HP Customized ESXi Image, locate your VMware version.

• To download the HP custom build .ISO, click Download here. The .ISO is required
for all ProLiant G7 server blades and Gen8 server blades using the HP FlexFabric
FlexibleLOM.

• To download the individual drivers and agents, click Contents of above images
available here.

Collect information required for the update
Collect the following information before performing the update steps in “Installation instructions”
(page 12):

• IP address and administrative credentials for all primary OAs in the environment

• Administrative credentials for all VCMs in the environment

• Administrator level login credentials for all server blade iLOs in the environment

• The management (host) IP address and administrator-level login credentials of Windows and
Linux services running on the server blade

Prepare for the update
To prepare for the update, copy the firmware downloaded in “Perform downloads” (page 10) into
the same directory on the CMS where the HP SPP DVD files were copied.
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Installation instructions
Perform the following steps to update the Matrix environment. If the Matrix environment has HP
3PAR StorServ Storage, contact your HP 3PAR service representative to perform any updates
needed on the storage system before proceeding with the rest of these instructions.

IMPORTANT: Before installing any HP 3PAR StoreServ Storage updates, see the HP CloudSystem
Matrix 7.5 Compatibility Chart and the HP Insight Management 7.5 Support Matrix at http://
www.hp.com/go/matrixoe/docs.

Step 1: Install the CloudSystem Matrix Versioning Tool
Install the CloudSystem Matrix Versioning Tool on the CMS.
1. Double-click the installer file, for example cp019311.exe.
2. Click Run in the pop-up window.
3. Click Extract.
4. Select or create a new directory where you want to extract the file and click OK.
5. Click Close on the installer window.
6. Copy the XML files downloaded in “Perform downloads” (page 10) to the directory where

the Versioning Tool was extracted.

Step 2: Use the Versioning Tool to set the version
The Versioning Tool can set the CloudSystem Matrix version to an updated version that is installable
for your particular CloudSystem Matrix environment. To use the Versioning Tool:
1. Open the folder where you saved the Versioning Tool files and double-click MatrixIDGUI.

If you are running the Versioning Tool for the first time, the HP End User License Agreement
screen appears. Accept the licensing terms and click Next.
The Welcome screen appears.

2. On the Welcome screen:
• Click the What's New tab to review new features in the tool.

• Click the Usage tab to review instructions for using the tool.

• Click the About tab to review information about the tool.

12 Installation and configuration

http://www.hp.com/go/matrixoe/docs
http://www.hp.com/go/matrixoe/docs


3. Click Next.
A pop-up window appears if the MatrixConfig.xml file is missing from the working
directory. Click Browse to search for and select the appropriate MatrixConfig.xml file.

4. Click Continue to open the Onboard Administrator (Active) login screen.

5. Enter the OA credentials in the IPv4/IPv6 address or DNS name, User name, and Password
fields. Click Login.

NOTE: OA login credentials are case sensitive.
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6. The tool displays the current CloudSystem Matrix version. To set the new CloudSystem Matrix
version, select the version and click Submit.

NOTE: Setting the CloudSystem Matrix version does not update the software or firmware in
the enclosure. Only the CloudSystem Matrix version number that is used to identify the software
and firmware versions that are currently running is set.

7. The tool displays the new CloudSystem Matrix version that was set on the enclosure. Click
Logout to log out of OA.

8. For each additional enclosure, repeat steps 5 through 7. When you are finished updating the
CloudSystem Matrix versions, click Exit to log out of OA and close the tool.

Step 3: Update ProLiant enclosures, firmware, agents, and drivers

NOTE: Perform the following procedures for ProLiant server blades only. For Integrity server
blades, skip to “Step 4: Update Integrity enclosures, firmware, agents, and drivers” (page 22).

Update enclosures and managed server blades

Update OA, iLOs, VC modules, and managed server blades (server blades with an operating
system installed). Be sure to download firmware versions that are not on the SPP as described in
“Perform downloads” (page 10) and copy all downloaded firmware components to the CMS as
described in “Prepare for the update” (page 11).
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1. Determine how you want to deploy the components, in offline or online mode. Keep in mind
the following guidelines:
• Spare server blades (without an OS installed) must be updated offline so that the server

blades can be booted to the SPP.
• For server blades with an Emulex FC HBA running SLES 11 with an errata Kernel, the

Emulex FC HBA must be updated offline.
• VM host server blades (server blades running VMware or Windows Hyper-V) must be

updated offline so that the server blades can be booted to the SPP. Consider the following
options and perform the one most suited to your CloudSystem Matrix environment.

◦ Move the VMs to run on another VM host. After installing the components from the
SPP, move the VMs back to the original VM host, as needed.

◦ Schedule downtime for the VM host and all the VMs it hosts. Back up the VM host.
After installing the components from the SPP, restore the VM host from the backup.

2. Browse to the directory you created in “Prepare for the update” (page 11) that includes the
downloaded firmware component files and double-click hpsum.bat.

3. The HP Smart Update Manager will open in the browser.

4. Click on Baseline Library and a screen will appear that shows baselines and additional
packages to update your nodes. Baselines include HP SPP, HP Integrity bundle, or custom
baselines. Additional packages are directories that hold hot-fixes, updates or components that
are not part of SPP.
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5. If the SPP required for the CloudSystem Matrix version being installed (as per the compatibility
chart) is not already added, you must add it as a baseline by clicking + Add Baselines.

6. Create a custom baseline if additional components are required but not part of SPP as per
the compatibility chart. From the Baseline Library screen, click Actions→Create Custom to
create a custom baseline.

NOTE: For more detailed information on baselines and custom baselines, see the HP Smart
Update Manager User Guide at http://www.hp.com/support/HP_SUM_UG_en.

7. Return to the HP Smart Upate Manager main menu and click on Nodes. The Nodes screen is
displayed.

8. To add a node, click on the +Add Node button.

9. Under the Nodes heading, enter the following information:
a. Select Add a single node by IP/DNS name.
b. Enter the node IP address or DNS name.
c. Enter a description for the node.
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d. In the Type field, select the node type. If you do not know the node type, select Unknown.
During the inventory process, HP SUM determines the node type.

e. If you want, select the baseline, additional package, or both to apply to this node.
f. Select one of the following:

• Use current credentials (requires existing trust relationship with the node): This option
is for Windows nodes only.

• Enter administrator credentials
g. Click Add.

10. From the Nodes screen, highlight the node and then click Actions→Inventory.
11. Select a baseline/custom baseline, additional package, or both as per the compatibility chart

to apply to the node.
12. Click Inventory.
13. Return to the HP SUM main menu and click Deploy.
14. Select the node you want to update and then click Actions→Review/Deploy.

NOTE: For more detailed information on deployment options , see the HP Smart Update
Manager User Guide at http://www.hp.com/support/HP_SUM_UG_en.

15. Click Analysis, and then click Deploy to begin the deployment.
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16. Once all updates are complete, click on the Session button to log out and shut down HP SUM.

Update spare G5, G6, G7, and Gen8 server blades with SPP data

Update spare G5, G6, G7, and Gen8 server blades (without an OS installed) with firmware from
the SPP. These server blades must be updated offline so that the server blades can be booted to
the SPP.
If you need to update firmware not included on the SPP (as indicated by the HP CloudSystem Matrix
Compatibility Chart), first update the server blades with the firmware included on the SPP. Then
perform the steps in “Update spare server blades with firmware not included on the SPP” (page 21).
1. Using a DVD burning tool, burn the SPP ISO image downloaded in “Perform downloads”

(page 10). The ISO must be burned to the DVD as an image, not as a file, or the DVD will
not be bootable. After burning the DVD, boot it on one of the server blades to verify that the
burn was successful.

2. Connect a USB DVD drive to the OA USB port and insert the DVD you created in the previous
step.

3. Log in to the OA web interface and select Enclosure information→Enclosure Settings→DVD
Drive.

4. Select all spare server blades. Verify the Power State is Off for all server blades. If necessary,
use the Virtual Power menu to power off any spare server blades.
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5. Select DVD→Connect to Enclosure DVD. Wait for the iLO DVD Status for all the spare blades
to show Connected.
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6. Select all spare server blades, and then select Virtual Power→Momentary Press to power on
the server blades.

The server blades will now boot to the DVD. HP SUM runs automatically and updates all components
from the DVD. Wait for the iLO DVD Status for all spare blades to show Disconnected, which
indicates that HP SUM updates are complete.
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Update spare server blades with firmware not included on the SPP

This section describes the steps to update the CloudSystem Matrix server blade system ROMs, the
HBA/Converged Network Adapter firmware, and other firmware not included on the SPP. For
VMware ESX/ESXi/vSphere environments, see “Update the VM host G5, G6, G7, and Gen8
server blades ” (page 21).

IMPORTANT: This update requires system downtime.

1. Create a bootable USB flash drive from the SPP DVD.
a. In the directory where the SPP DVD was copied in “Prepare for the update” (page 11),

locate the /usb/hpusbkey directory and double-click the hpusbkey.exe file.
b. Click Next at the splash screen.
c. Read the EULA, select Agree, and then click Next.
d. Place the USB flash drive in an available USB port. Insert the SPP DVD in the optical drive

or mount the ISO image, and then click Next.
e. Select the drive letter of the source (CD, DVD, or ISO), select the drive letter of the target

USB flash drive, and then click Next.

CAUTION: All data on the target USB flash drive will be deleted.

f. Click Next on the warning message screen. The USB flash drive is formatted and the DVD
contents are copied to the USB flash drive.

g. Click Finish to display the README.TXT file from the CD-ROM that you just transferred.
2. Be sure that all downloaded firmware component files are located in a directory on the CMS

as described in “Prepare for the update” (page 11).
3. Link the newly created USB flash drive to the iLO virtual media for each server blade.
4. Boot from the USB flash drive and follow the HP SUM steps to complete the firmware update.

NOTE: A reboot is required for any server blade system ROM update to take effect.

Update the VM host G5, G6, G7, and Gen8 server blades

Update the VM host server blades (server blades running VMware or Windows Hyper-V) for all
G5, G6, G7, and Gen8 server blades. These server blades must be updated offline so that they
can be booted to the SPP. Consider the following options and perform the one most suited to your
CloudSystem Matrix environment:

• Move the VMs to run on another VM host while performing the steps in “Update spare G5,
G6, G7, and Gen8 server blades with SPP data” (page 18). Update the VM hosts with the
latest HP custom build .ISO or the individual drivers and agents downloaded in “Perform
downloads” (page 10). For more information, see the Getting Started Guide at http://
h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?
contentType=SupportManual&lang=en&cc=us&docIndexId=64179&taskId=101&
prodTypeId=18964&prodSeriesId=420496. When the update completes, move the VMs
back to the original VM host, as needed.

• Schedule downtime for the VM host and all VMs it hosts. Back up the VM host and perform
the steps in “Update spare G5, G6, G7, and Gen8 server blades with SPP data” (page 18)
during the planned downtime. Update the VM hosts with the latest HP custom build .ISO or
the individual drivers and agents downloaded in “Perform downloads” (page 10). For more
information, see the Getting Started Guide at http://h20000.www2.hp.com/bizsupport/
TechSupport/DocumentIndex.jsp?contentType=SupportManual&lang=en&cc=us&
docIndexId=64179&taskId=101&prodTypeId=18964&prodSeriesId=420496. When the
update completes, restore the VM host from the backup.
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Step 4: Update Integrity enclosures, firmware, agents, and drivers
Update the firmware and drivers on all Integrity server blades in the enclosure. For additional
information see the README.TXT file included in each bundle.

Update the BL860c i2/i4, BL870c i2/i4, and BL890c i2/i4 HP Integrity server blades using the
HP SUM Integrity bundle
Update the HP Integrity server blade firmware using an Integrity-specific HP SUM bundle for the
Integrity BL860c i2, BL870c i2, BL890c i2, BL860c i4, BL870c i4, and BL890c i4 server blades.
HP recommends using the CMS server for extracting the HP SUM Integrity bundle and running HP
SUM, since it is guaranteed to have connectivity to all of the server blades in the CloudSystem
Matrix environment. Perform the following steps on the CMS server.

NOTE: The update can be done while a server blade is running, but the new firmware is not
activated until the server blade is rebooted. HP SUM defaults to “update but do not activate” (defer
reboot until later), although an option can be selected to “activate firmware” (reboot on completion).

Perform the following steps on the CMS:
1. Extract the bundle downloaded in “Perform downloads” (page 10):

• For Windows: Double-click <filename>.exe and click Extract.

• For Linux: Run the gunzip <filename>.tar.gz; tar -xvf <filename>.tar
command.
The contents of the bundle are extracted to the folder where the bundle file is located.
HP SUM and the firmware components will reside in the same folder.

2. Double-click HPSUM.bat to start HP SUM from the extracted folder. HP SUM will be launched
on your default browser.
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3. On the Welcome Screen, click Baseline Library. The Baseline Library screen appears. The
directory where HP SUM is running is automatically added as the default repository. HP SUM
builds an inventory of firmware bundles/packages that can be used to update firmware.

NOTE: You can optionally have HP SUM check ftp.hp.com for additional firmware or
software smart components, such as newer components for servers supported in this bundle,
and components for other server types.

4. When the Status appears Inventory Completed, click on the HP Smart Update Manager 6.2
menu and select Options→Nodes.

5. Click +Add Node. The Add New screen appears.
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6. Enter the IP address or DNS name, description of the node, and select the type of node you
are adding. Check the Auto Add Assocated Nodes box to add associated targets along with
the Active OA.

NOTE: During the inventory process, HP SUM determines the node types.

7. Select the Baseline from the Baseline to Apply menu to inventory the target node.
8. Provide credential details for the target node and then click on the Add button.

9. Click on the yellow banner message to pop up the Inventory dialogue box and then click on
Inventory to continue the process.
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10. Once the inventory is complete, the status is shown as Ready for deployment.

11. Click on the Ready for deployment status to proceed with deployment.
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12. Click on Deploy to update the target node.
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13. Once the update is complete, click on the Session button to log out and shut down HP SUM.

NOTE: For more detailed instructions, see the HP Smart Update Manager User Guide at http://
www.hp.com/support/HP_SUM_UG_en.

Update the HP-UX server

1. Start HP SUM to update HP-UX.
2. From the Welcome Screen, click Next. The Source Selections screen appears.
3. Click Next. The Select Targets screen appears.
4. Click Add Single Target. The Add New Target screen appears.

5. Enter the IP/DNS address, target type, description, and login credentials for the HP-UX server.
Click OK and wait for HP SUM to discover the server.

6. Click Next. The Review/Install Updates screen appears.
7. If you need to set force installation options, click Installation Options.
8. Set the appropriate force installation options and click OK.
9. If you need to set reboot options, click Reboot Options.
10. Set the appropriate reboot options and click OK.
11. Click Install and wait for HP SUM to complete all updates. A message appears indicating a

successful install.
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12. If you did not set the option to reboot before the installation, click Reboot Now to reboot HP-UX
after installation.

Update the SAS controller for Integrity server blades
The embedded SAS controller firmware for Integrity BL8x0c i4 server blades is not included in the
bundle if the SAS version currently installed is 5.82. If the version currently installed is 5.84 or
greater, then the current firmware is found on the bundle.
1. Download the firmware:

a. From http://www.hp.com/go/hpsc, under Find an HP product by search, enter the server
blade model (for example, BL860c i4).

b. Click View and download all drivers, software and firmware for this product.
c. Select HP-UX 11.31(IA).
d. Click Firmware - Storage Controller.
e. Click Download for the appropriate SAS IO firmware.

2. Follow the instructions included with the HP SUM Integrity CloudSystem Matrix bundle to
complete the update.

Additional installation and configuration requirements

Install Microsoft hotfix for Windows 2008 R2 or Windows 2008 R2 SP1
Microsoft KB2577795 is required to fix a socket leak which causes network communication issues.
The hotfix does not come with Windows updates and must be installed manually on the CMS.
Install the hotfix at http://support.microsoft.com/default.aspx?scid=kb;EN-US;2577795.
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Patches required for Microsoft Windows Server 2008 with Hyper-V systems
Install required patches on the Hyper-V hosts, and then install or update Hyper-V Integration Services
from the updated host to each VM guest as a precaution. Not all patches affect Integration Services
on the guests.

• For Microsoft Windows Server 2008 SP2 with Hyper-V, to fix a hang issue for host servers
running several simultaneous VM operations, install the patch at http://support.microsoft.com/
kb/980081.

• If a Windows 2008 or 2008 R2 Hyper-V server will be running any version of Windows
2012, install the patch located at http://support.microsoft.com/kb/2744129.

For more information about other patches that may be required for later editions of Microsoft
Windows Server 2008 R2, see the Managing Microsoft Windows Server 2008 Hyper-V with HP
Insight Software technology brief at:
http://www.hp.com/go/matrixoe/docs

Install and configure HP 3PAR StoreServ Storage
HP 3PAR StoreServ Storage must be installed, configured, and fully operational before initiating
an HP CloudSystem Matrix Starter Kit Implementation Service. Use the HP 3PAR StoreServ Storage
Software Installation and Startup Service, included with the storage device, to complete the required
HP 3PAR StoreServ Storage installation and configuration.

Manually update Integrity I/O firmware if an update is needed before OS installation
The HP SUM Integrity CloudSystem Matrix bundle version 7.5 supports online updates of I/O
firmware on Integrity server blades only. If an I/O firmware update is required before operating
system installation, the I/O firmware must be manually updated using EFI packages.
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3 Issues and suggested actions
Issues and limitations of this release are listed below, organized by HP Insight Management product
or functional area. The following categories are used:
Limitations Limitations of the implemented functions and features of this release
Major issues Issues that may significantly affect functionality and usability in this release
Minor issues Issues that may be noticeable but do not have a significant impact on

functionality or usability

HP Insight managed system setup wizard

Limitations

Privilege elevation configurations that require a password by the privilege elevation tool are not
supported

The Insight managed system setup wizard only supports privilege elevation on a CMS that has
privilege elevation configured so that a password is not required by the tool (such as su and
sudo). If you attempt to configure features while privilege elevation is turned on and a password
is required, you may see failures in the wizard's execution output.
Suggested action
If a feature cannot be configured correctly because of privilege elevation password requirements,
configure the feature outside of the managed system setup wizard.
To turn off the requirement for a password, use the Systems Insight Manager
Options→Security→Privilege Elevation menu, and uncheck the A password is required for this
privilege elevation tool checkbox. Systems managed by the CMS must be reconfigured to reflect
this configuration change.

HP Insight Control software
For complete release notes for HP Insight Control software, see the HP Insight Control 7.5 Release
Notes.

HP Insight Control power management

Limitations

DCPC works only on the primary address of a system
Data Center Power Control (DCPC) works only on the primary address of a system. It cannot detect
a system with a non-primary address.
Suggested action
Provide the primary IP address of target node while creating a rule in DCPC.

Power delivery devices should not utilize a resolvable hostname
If a power delivery device is created with a name that is a resolvable hostname, HP Systems Insight
Manager (HP SIM) discovery may change the type to match that of the hostname. When this occurs,
power management analysis views that attempt to display the power delivery device may report
the following error message:
Circuit {Name} does not exist.

Suggested action
Correct the system type of the device to be a power delivery device:
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1. In the Systems Insight Manager Search box, enter the device name.
2. On the System page for the device, click the device name link.
3. Click the Tools & Links tab.
4. Click Edit System Properties.
5. Set the System type: to Power Delivery Device.
6. Be sure that the Prevent the Discovery, Identification and Data Collection processes from

changing these system properties option is selected.
7. Click OK.

Major issues

Incomplete display of Power/thermal page when two or more (multiple) servers are selected
When you select multiple servers or collection of servers and try to display the Power/thermal data
or graph from Report→Power Management→Display Power/thermal data, the entire Display
Power/thermal page and graphs are not displayed. You can only see the graph settings and partial
graph being visible and rest of the page is blank.
Suggested action
To solve this issue:
1. Click on Print Tab/Option on the page or right click and save the page for complete or full

visibility of graph.
2. To set/manage power management actions, perform the tasks via menu options.
Alternatively, collapse the Graphs Tab in Display Power/Thermal data Page to view the Power
management Actions Tabs and all related operations can be performed by expanding the Power
management actions Tab.

Scheduled tasks for HP Power Regulator or Power Cap are not listed in the “Scheduled tasks” list
or are not editable
If you scheduled a Power Regulator or Power Cap task using Power Management 6.0 or earlier
and then upgraded your system to Power Management 7.2.x, the task may not be listed in the
Scheduled tasks list or may result in failure when you try to edit the task.
Suggested action
Delete the existing Power Regulator or Power Cap task and schedule a new task.

Minor issues

Racks and data center do not have power data after discovery
Unmanaged nodes (racks and data center) do not have power data after discovery.
Suggested action
For the unmanaged node to receive power data, do one of the following:

• Calculate power history by selecting Reports→Power Management→Calculate Power History.
or

• Click Refresh Data on the Display Power/Thermal data page to refresh the data for the
unmanaged node.

Web browser crashes while creating or editing a data center or rack
The web browser crashes while creating or editing a data center or rack. The crash information
dialog in Mozilla Firefox (about:crashes) may contain the signature:
Caused by a plugin: Shockwave Flash (npswf32.dll)

Suggested action
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Download and install the supported version of Adobe Flash player from: http://get.adobe.com/
flashplayer.

Unable to shut down the hosts and guests in either a forced or graceful manner
VMware ESXi/vSphere versions do not support SSH capability.
Suggested action
Shut down the guests or hosts manually.

Inconsistent system details may appear when multiple open browser instances share the same user
session
If you have multiple browser windows open to view different systems and these browser instances
share the same browser session, inconsistent system detail data may be displayed inside some of
the browser instances.
Suggested action
Refresh the browser window that displays inconsistent system details. Start and sign in to HP SIM
using a separate browser session:
• For Microsoft Internet Explorer 8, click File->New Session to start the new browser session.

• For Mozilla Firefox, start multiple browser sessions using separate profiles. For example,
firefox.exe -no-remote -P profile_name.

Graphs and reports do not display when the time difference between the CMS and OA is more
than 24 hours
Insight Control power management cannot display power, utilization, and temperature graphs if
the time difference between the CMS and managed node is more than 24 hours, even though
data collection status reports are successful. Power data is stored based on the time set on the
managed node.
Suggested action
If necessary, update the date and time on the CMS and managed nodes to be consistent with the
respective time zones.

HP Insight Control server migration

Limitations

API-CLI Limitation / Requirement
Only primary partition migrations are supported using APIs migrateToProliant /
migrateToVM.
Requirement
1. Prior to SLES 12 migration to a destination server in EFI mode, you must install the grub2-efi

package on the source server.
2. Prior to SLES 11 SP2 migrations to a destination server configured with iSCSI disks, you need

to install open-iSCSI package on the source server.
3. Prior to SLES 11 SP3 migrations to a destination server configured with iSCSI disks, you must

install the open-iSCSI package on the source server.

Agent launch from the CMS to a source server with “, :, or \ characters in the password is not
supported
Windows source agent deployment does not support Administrator passwords that contain the “,
:, or \ characters.
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Major issues

Operating system does not boot on ESXi with EFI mode after the successful migration of RHEL 6.5
and 6.6 64-bit with T-Boot package installed
Start the X2V migration of RHEL 6.5 and 6.6 64-bit on destination ESXi configured with EFI mode.
After the successful migration, the operating system does not boot on destination ESXi.
Suggested action
RHEL 6.5 and 6.6 64-bit with T-Boot package in EFI mode is not supported.

Controller name is not displayed in the migration wizard
Causes
1. The controller name is not getting displayed for P246br or P840i controller.
2. The controller name is not getting detected in the migration wizard after making changes from

HP Smart Storage Administrator (HP SSA).
Prepare a destination server with P246br or P840i controller and IP 2.10 flashed, do not create
any logical drives. Perform an auto boot on the destination and proceed till step 5 of the migration
wizard. Observe that disks will not get detected in the wizard. Now create a logical drive through
HP SSA from the destination agent page and refresh the migration wizard page. Observe that the
logical drives created through HP SSA is getting detected now, however the controller name is not
getting detected in the migration wizard.
Suggested action
You can continue with migration even if controller name is not displayed. If more that one controller
is present, to avoid confusion match the device name. For example, /dev/sda and disk size
displayed in wizard with the one displayed in destination UI.

The disk is not detected for B140i Cntrl after auto boot in EFI mode
If the server is in legacy mode and auto boot is performed in EFI mode, then the disk is not getting
detected after the auto boot in step 5 of B140i Controller wizard.
Suggested action
Before initiating auto-boot make sure the server is set in EFI boot mode.

Data is not reflected on the destination server after SAN migration
Initiate a P2P migration, where source is RHEL 5.9 X32 OS on 82B FC controller, configured on
ML310e Gen8, retaining data in an extended partition, configured on B110i controller. The
destination is configured on CN1000Q iSCSI and P410i controller.
The OS migrated to P410i controller and extended partition migrated to CN1000Q iSCSI. After
the successful migration, the OS boots up but the data on the extended partition does not reflect
on the destination.
Suggested action
Try mounting the secondary controller disk on the destination post-migration boot.

RHEL 6.6 OS boots into kernel panic
Post RHEL 6.6 migration, where source OS is installed on iSCSI disk and destination server that
has local storage controller, the RHEL 6.6 OS may boot into kernel panic.
Suggested action
During OS boot up in grub menu, remove the iscsi_firmware boot parameter and continue
booting. As a permanent solution for subsequent boots, remove the iscsi_firmware parameter
from the grub.cfg (grub config) file available at /boot/grub2/grub.cfg.
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Operating system fails to boot on a destination server after migration when logical volumes are
not erased on destination disks
After a completed Insight Control server migration, the OS may not boot on the destination server
if the server is repurposed and the following criteria are met:
1. The primary storage controller is reconfigured from RAID mode to non-RAID mode without

erasing the existing logical volumes.
2. The server is designated as a destination server by Insight Control server migration.
Suggested action
Do one of the following actions:

• Configure the controller in RAID mode, erase all logical volumes, reconfigure the controller
into non-RAID mode, and then run the migration again.

• Configure the server to use the RAID mode of the controller and then run the migration again.

Minor issues

Migration of Windows domain controller may result into Blue Screen error with error no.
0xc0000001
Initiate a X2P migration of Windows 2008 SP2 x32 configured as primary domain controller on
ML110 G7 configured with B110i G7. After the successful migration, BSOD is observed on
destination.
Suggested action
Reboot the server in Directory Service Restore Mode and execute the below commands in command
prompt:
1. Restart the server and press F8 key, select Directory Services restore mode.
2. Login with the local administrator username and password, open command prompt, and enter

the following commands:
a. cd \windows\system32

b. NTDSUTIL

c. activate instance NTDS

d. files

3. If you encounter an error stating that the Jet engine could not be initialized, then exit out of
ntdsutil, and enter the following commands:
a. cd\

b. md backupad

c. cd\windows\ntds

d. copy ntds.dit c:\backupad

e. cd \windows\system32

f. esentutl /g c:\windows\ntds\ntds.dit

4. This will perform an integrity check, (the results indicate that the jet database is corrupt).
5. Enter esentutl /p c:\windows\ntds\ntds.dit
6. Agree with the prompt, and enter the following commandss:

a. cd \windows\ntds

b. move *.log c:\backupad (or delete the log files).

By following the steps, the repair is complete. Verify if the repair is successful by entering the
following commands:
1. cd \windows\system32

2. ntdsutil

3. activate instance ntds
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4. files (there should be no errors)
5. info (the file info should appear correctly)

Post RHEL 6.6 OS migration on destination server, the OS boot up appears unresponsive with an
error message
Post RHEL 6.6 OS migration on destination server, the OS boot up appears unresponsive with the
following message:
Starting udev: udevd[402]: GOTO 'pulseaudio_check_usb' has no matching label in: 
'/lib/udev/rules.d/90-pulseaudio.rules' udevd[402]: GOTO 'pulseaudio_check_usb' has no matching label in: 
'/lib/udev/rules.d/90-pulseaudio.rules.

Suggested action
This is a known issue with RHEL 6.6 OS migration. For more information, see https://
bugzilla.redhat.com/show_bug.cgi?id=1159711 and http://bugs.centos.org/view.php?id=7772.

During the X2V migration cancellation of auto-boot is not allowed
When an auto boot is performed for an X2V migration with Hyper-V as the destination VM Host,
under View Status/Logs tab when the cancel button is clicked a confirmation message is displayed.
However, on confirming by clicking on the OK button, the auto boot is not canceled.
Suggested action
During the ISO copy progress the task cannot be canceled. During VM creation the task can be
canceled.

Post RHEL 7 migration on Qlogic iSCSI Storage Controllers, the OS does not boot up and ends
up in Dracut shell
Suggested action
If this issue is seen on RHEL 7 OS with Qlogic iSCSI Storage Controllers, during start up in grub
menu, remove the rd.iscsi.firmware boot parameter and continue booting. As a permanent
solution for subsequent boots, remove the rd.iscsi.firmware parameter from the grub.cfg
file available at /boot/grub2/grub.cfg.

HP Insight Control server provisioning
For additional issues and suggested actions, see the Troubleshooting index in the Insight Control
server provisioning Online Help.

PXE-less boot consideration
Use of HP Intelligent Provisioning may not be supported by all server configurations or firmware
versions. Consult the HP Insight Management Support Matrix for information about configurations
that do not support Intelligent Provisioning. To globally disable use of Intelligent Provisioning set
the enable.hp.intelligent.provisioning.boot property to False in the
hpio.properties file. To disable its use on a per-server basis, use the following procedure to
delete all iLO users from the system:
1. Navigate to the Onboard Administrator.
2. Select the device bay for the server where you want to remove the iLO credentials.
3. Click the Web Administration link.
4. Click the Administration→User Administration menu.
5. Select all local users.
6. Click the Delete button.
7. Re-run the HP Systems Insight Management discovery task for the target system or enclosure.

NOTE: This disables the ability to log in directly to the iLO, but the Onboard Administrator
continues to perform operations and you can log in to iLO via the Onboard Administrator.
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First Time Setup Issues

Console browser may display an empty Servers screen after first time network setup
After entering network information on the console during the initial appliance setup, click OK. The
Applying network settings screen displays initially, but then the Servers screen displays a message
stating that servers cannot be retrieved. This behavior is expected and can be ignored. Do not
attempt to perform any operations on the appliance. Wait one to two minutes for the appliance
to reboot automatically.

Upgrade issues

After updating server provisioning appliance, Settings UI page may display DHCP error
If your Insight Control server provisioning appliance is not providing DHCP service at the start of
an update (such as when using an external DHCP server), the message The DHCP settings
do not conform. The network specification is missing. may appear on the
Settings page after the update is complete.
Suggested action
To resolve this error, navigate to the Edit DHCP page, and select None for the Service provided
by appliance setting.

Limitations

Installing SLES 11.3 to any Gen9 servers requires a Bootable Driver Kit (kISO)
To install SLES 11.3 on any ProLiant Gen9 servers, a special Bootable Driver Kit (previously called
kISO) must be added to the SLES distribution on the media server.
Suggested action
Perform the following steps to add Bootable Driver Kit to the SLES distribution on the media server:
1. Download the kit located at http://drivers.suse.com/hp/HP-ProLiant-Gen9.
2. Open the ISO.
3. On your media server, make a copy of the SLES 11.3 distribution and place it in a properly

named folder. For example, /Media/SLES-11SP3-kISO-x86_64.

NOTE: You may want to keep your original as this kit is only used for Gen9 servers.

4. In the new folder you created in step 3, create an addon directory under new repository
directory. For example, Media/SLES-11SP3-kISO-x86_64/addon.

5. Copy the kit contents to the addon directory.
6. Replace the original installation kernel and initrd files with the ones from the kit addon directory

as follows:
a. Copy addon/boot/x86_64/loader/initrd to boot/x86_64/loader/initrd.
b. Copy addon/boot/x86_64/loader/linux to boot/x86_64/loader/linux.

7. In the appliance UI, find the SLES11 SP3 Build Plan and select Save As to create an OS Build
Plan from the existing SLES11 SP3 Build Plan that can be edited.

8. Edit the Set Media Source step in the new Build Plan and change the parameter to point
to the new directory.

9. Delete the ProLiant Drivers for SLES 11 SP3 x64 step as the kit has all the necessary
drivers.

RHEL 7.0 limitations when using FCoE
A RHEL 7.0 scripted installation Build Plan may fail at the final Wait for HP SA Agent step when
using FCoE with certain HP FlexFabric/StoreFabric Adapters. The server may hang during the final
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reboot, or may kernel panic when trying to boot the RHEL 7.0 production OS. This is due to a race
condition when rebooting too soon after the installation is completed.
The following adapters are affected when used in FCoE mode:

• HP FlexFabric 10Gb 2-port 536FLB Adapter

• HP FlexFabric 20Gb 2-port 630FLB Adapter

• HP FlexFabric 20Gb 2-port 630M Adapter

• HP FlexFabric 10Gb 2-port 534FLB Adapter

• HP FlexFabric 20Gb 2-port 630FLB Adapter
Suggested action
Make a copy of the Build Plan and insert a Sleep script step with the parameter --minutes=3
before the final Reboot step.

Intermittent boot failures when installing SLES 11 SP3 with FCoE
Intermittent failures are seen when installing SLES 11 SP3 to FCoE devices. The RPM installation
succeeds, but OS fails during the first reboot and the Build Plan fails with the error:
Step 22 of 22: Run OGFS Script 'Wait for HP SA Agent' Waiting for
registration of agent running on production OS Failed To Wait for HP
SA Agent: Timeout while waiting for agent

Wait for HP SA Agent failed with exit code 120.

Suggested action
Modify the disk partition section of the Autoyast file as follows:

• Use Save as to make copies of the SLES 11 SP3 Build Plan and configuration file.

• Edit the configuration file and uncomment the XML section that refers to the partitioning of the
disk.

• Edit the new Build Plan to use the newly modified configuration file.

Windows Build Plan may fail on UEFI enabled servers running in Legacy Mode
A Windows scripted installation Build Plan may fail at the Install and boot into local
WinPE step on any Gen9 or DL580Gen8 server configured in Legacy boot mode. The Build Plan
fails with the error message:
 Failed To Partition Disk for Windows: Cannot find on disk 0 a partition with label 'System'.

Suggested action
To fix this, perform the following steps:
1. Make a copy of the Build Plan.
2. Edit your copy of the Build Plan.
3. Before the Install and boot into local WinPE step, add a Prepare Disks on HP ProLiant

Gen8 step.
4. Save the Build Plan and use that copy.

RHEL driver name change may cause problems when using different driver packages
In the 2014.09.0 RHEL driver packages delivered with the appliance, the name of the Mellanox
driver has changed from that of previous driver releases. The HP provided RHEL kickstart
files are updated to match the new driver name, however, if you choose to use an older kickstart
file with the new driver packages, or if you choose to use a newer kickstart file with older
driver packages, your Build Plans fail.
Suggested action
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Make sure the driver called out in the kickstart file matches the version of the driver package
you are using.

• RHEL driver packages version 2014.09.0 — driver name is kmod-mlnx-en

• RHEL driver packages prior to 2014.09.0 — driver name is kmod-mellanox-mlnx-en

PXE-less installations of Windows may fail on the Targets with HP SN1000Q HBA connected to
a SAN
During PXE-less installations of Windows, the Install and boot into local WinPE Build Plan step may
fail trying to partition the disk on the Target server when connected to a SAN with any of the
following HBA cards:

• HP StoreFabric SN1000Q 16GB 1-port PCIe Fibre Channel Host Bus Adapter

• HP StoreFabric SN1000Q 16GB 2-port PCIe Fibre Channel Host Bus Adapter
Suggested action
Perform the installation using PXE, by editing the Boot step and adding the parameters
--method=network –force.

SLES11SP2 may fail on servers with P410i Smart Array Controller
On servers with a P410i Smart Array, the SLES 11.2 scripted installation Build Plan fails on the
last step of the Build Plan. The remote console shows an error where the root disk is not found.
This is due to the SLES installer uses the hpsa driver, but the installed kernel uses the cciss driver.
Suggested action
Create a custom attribute called kernel_arguments and set it to the value
brokenmodules=hpsa. By labeling the hpsa driver as broken, the installation succeeds.

Server provisioning appliance restart does not log users out
When a password is compromised, some administrators might use an appliance restart in an
attempt to log out all users. However, on restart of the IC server provisioning appliance via the
Settings page, users are not logged out, despite a message indicating that all logged-in users will
be logged out.
Suggested action
The workaround is to delete the user whose password is compromised. This will result in the user
being logged out without having to restart the server provisioning appliance. An administrator can
then re-add the user and assign a new password.

Post-install network configuration does not work on Windows servers that have been added to a
domain
The post-installation network configuration process does not operate properly on Windows servers
that have been added to a domain.
Suggested action
Perform all network configuration tasks before adding the server to a domain.

Server provisioning appliance may be left unusable if shutdown ungracefully
If the appliance is shut down abruptly as a result of an issue such as a power failure, storage
disconnection, or forced power off, on very rare occasions, the appliance disk may become
corrupted, and upon restart, will prompt for a password to manually run fsck. Unfortunately, the
supported mechanisms of getting the root password are not enabled at this early stage in the boot,
and hence the appliance is left unusable.
Suggested action
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Revert to a previously created VM snapshot, if one is available. If not, create a new server
provisioning appliance from the original image and then restore a backup.

Active Directory integration assumes default schema
When integrating with Microsoft's Active Directory (AD) and specifying the directory search context
it is assumed that the directory is using the default AD schema where users and groups are both
parented under a common container object. For example, users and groups parented under:
CN=Users, DC=example, DC=com.
If the users and groups directory objects do not have a common parent, assigning roles to a
directory group will fail.
Suggested action
If your Active Directory does not satisfy this limitation, you can use local users on the server
provisioning appliance instead of directory integration for authentication.

Linux SPP Upgrade from 2013.09C to 2014.06 causes reboot hang
When performing an online Linux installation of SPP version 2014.06 to a server already running
SPP version 2013.09C and with a B120i or B320i Smart Array controller, the SPP installation fails
with error code 6 at the Wait for HP SA Agent step, as the target server hangs during reboot.
Suggested action
There are two ways to work around this issue:
1. Modify the SPP Build Plan to add a three minute delay after the SPP installation and before

the reboot. To do this, add a sleep step with a parameter --minutes=3 to the Build Plan
just after the Install Linux SPP step.

2. Remove the hp-health component for SLES from the SPP directory on the media server. The
component has the following naming convention: hp-health-*.sles11.x86_64.rpm

Major issues

When using a Directory Server, group names are required to be in English
Any non-English group names added to the appliance cannot be viewed and deleted.
Suggested action
Ensure that all the group names intended for use by Insight Control server provisioning are in
English.

Configure Network issues with RHEL 7
When using the Configure Network feature on a RHEL 7 system, there are some restrictions.

• You cannot set the domain name.

• If using KVM, the bridge interface BR0 does not get configured.
Suggested action
Set the domain name of the server and IP of the deployment NIC during OS installation time or
manually.

The ProLiant SW - Install Linux SPP Build Plan Fails on “Wait for Agent” Step when run on Red Hat
Enterprise Linux 6.4
On servers with the NC375i NIC which uses the inbox netxen_nic driver, the server will kernel
panic when the SPP version 2013.09b is installed using the ProLiant SW - Install Linux SPP
Build Plan. This will cause the Build Plan to fail on the last "Wait for Agent" step.
Suggested action
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The reason for this failure is the netxen_nic driver that comes with the Red Hat Enterprise Linux 6.4
distribution. To work around this problem, the kmod-hpqlgc-nx_nic RPM should be installed from
the /root/DD-0 directory. You will need to specify --nodeps on the RPM command line. Once the
RPM has been installed, edit the file /etc/modprobe.d/blacklist.conf and add the line:
blacklist netxen_nic

Save the file, and reboot the server. Once the server is up and accessible, the SPP 2013.09b
Build Plan will run successfully.
Run the Prepare Server for reprovisioning OS Build Plan and then you can run another Build Plan
to configure a static IP address.

Linux SPP fails after step 2 for SPP 2013.09b
When installing the Service Pack for ProLiant (SPP) version 2013.09b on Linux operating systems
using the ProLiant SW - Install Linux SPP Build Plan, the plan fails at the hpqlgc QLogic component
package with exit code 255 and the hpsum_log.txt displays the following error:
No install was run, due to failed dependencies

The failure occurs at the dependency check and therefore, no driver or online firmware updates
will be attempted for any component in the SPP.
For Matrix OE customers, perform the following before running the ProLiant SW - Install Linux SPP
Build Plan:
Suggested action
From the IC server provisioning media server:
1. Remove the rpms that are failing on the dependency from the 2013.09b SPP directory (Media\

spp\2013.09b\hp\swpackages). The following table lists the rpm files to remove:

The hpqlgc files to remove from the SPP 2013.09b directoryLinux OS version

kmod-hpqlgc-nx_nic-4.0.590.6.1_3.0.13_0.27-1.rhel5u9.x86_64.rpmRed Hat Linux 5.9

kmod-hpqlgc-nx_nic-4.0.590.6.1_3.0.13_0.27-1.rhel6u4.x86_64.rpmRed Hat Linux 6.3

kmod-hpqlgc-nx_nic-4.0.590.6.1_3.0.13_0.27-1.rhel6u3.x86_64.rpmRed Hat Linux 6.4

hpqlgc-nx_nic-kmp-default-sles11sp2.x86_64.rpm

hpqlgc-nx_nic-kmp-xen-sles11sp2.x86_64.rpm

SUSE Linux 11
SP2

hpqlgc-nx_nic-kmp-default-sles11sp3.x86_64.rpm

hpqlgc-nx_nic-kmp-xen-sles11sp3.x86_64.rpm

SUSE Linux 11
SP3

2. To install the correct version of these RPM files, copy the files from the 2013.02 SPP directory
at \Media\spp\2013.02\hp\swpackages and paste them to the 2013.09 SPP directory
at \Media\spp\2013.09b\hp\swpackages.

The 2014.02.0 SPP has an iSCSI driver that causes issues with SLES11 SP2 and SLES11SP3 on
servers that have Emulex configured with iSCSI
For servers with SLES 11SP2, the following error message may be seen:
An error occured during the installation

For servers with SLES 11SP3, the following error message may be seen:
Installation of package ./suse/master-bboot-code-1.14-70.11.i586.rpm
failed

Suggested action
If you are attempting to install one of these OSs, you will need to modify the build plan to use the
driver package from the 2013.09b version of SPP instead of the 2014.02.0 version.
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As part of Disaster Recovery, VMware is returning the same UUID to VMM for both the live VM
and the shadowed VM that is no longer accessible on protected site. (Disaster recovery could be
triggered by using VMware vCenter SRM tool)
This a VMware issue.
Suggested action
If one or more hosts are disconnected or offline, do not bring them back online until ready to
complete the SRM Recovery process. If one or more hosts cannot access their storage, these hosts
must be shut down until the problem is resolved and the SRM Recovery process is ready to be
initiated.

Microsoft Windows 2012 and Microsoft Windows 2012 R2 guest NIC customization fails for
static IPv4 on Microsoft Windows 2012 R2 host
If you try to sysprep a Windows Server 2012, or Windows Server 2012 R2 running as a guest
on a Windows 2012 R2 Hyper-V host, the provided sysprep.xml file from VMM does not set the
IPv4 address properly. But, it does set the IPv6 address, and IPv4 DNS and gateway addresses.
Suggested action
If the VM has a static IP set before sysprep is run, this issue does not occur. Hence, just setting a
generic fake static IP v4 address prior to sysprep prevents this issue. Else, for Windows 8 Client
and Windows Server 2012 General Availability Update Rollup needs to be installed in the VM
before it is syspreped to prevent this issue. Here is the link to the KB 2756872 (http://
support.microsoft.com/kb/2756872) and a link to download the updates (http://
www.microsoft.com/en-us/download/details.aspx?id=34943).
As part of customization, If you create a guest of Microsoft Windows 2012 on Hyper-v 2012 R2
Host and if you try to run sysprep using the command
C:\Windows\System32\Sysprep\Sysprep.exe on the Guest VM, it fails on reboot with the
error vmbus.sys couldn’t be loaded.
To resolve this issue, the above Windows 8 Client and Windows Server 2012 General Availability
Update Rollup must be installed in the VM before sysprep is run.

Default gateway is not set on the provisioned VM for secondary NIC in dual NIC scenario
After successfully provisioning the VM, the default gateway is not set for the secondary NIC.
Suggested action
To access the IP addresses of secondary NIC, add the default gateway manually for the secondary
NIC.

Failure during upgrade of Matrix infrastructure orchestration 7.2.x to 7.4
If you are upgrading from HP Insight Management 7.2.x or later to HP Insight Management 7.4,
and you have Insight Control performance management and HP Matrix infrastructure orchestration
installed and configured on your highly available CMS with SQL Always On enabled, then this
issue may be applicable to your environment. You may skip this section if you do not have HP
Insight Control performance management and HP Matrix infrastructure orchestration installed and
configured in your environment.
While upgrading in the high availability CMS environment with Always On enabled, the installer
may result into following error or warning for HP Insight Control performance management and
HP Matrix infrastructure orchestration:

• For HP Insight Control performance management
SEVERE: The operation cannot be performed on database “PMP_V5_0” because it is involved in a database 
mirroring session or an availability group. Some operations are not allowed on a database that is 
participating in a database mirroring session or in an availability group.

• For HP Matrix infrastructure orchestration
Failed to set recovery mode to simple or auto close to false in HP Operations Orchestration database.
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Suggested action
Perform the following steps to avoid this error while upgrading the supported Insight Management
stack in a high availability environment with Always On database.
1. Remove the HP Insight Control performance management (PMP_V5_0) and HP infrastructure

orchestration (hpio, oo, and HPMOEMetering) databases, as applicable, from the Always
On Availability Group prior to the execution of upgrade from an earlier version of Insight
Management to the latest version. If the removed databases exist in any of the replica servers,
disconnect them from there to avoid any pending existing connections left for the removed
databases in the Availability Group. Skipping this step will cause a failure when an attempt
to add the removed databases back to the Availability database is made after the upgrade.
For more information, see Remove a Primary Database from an Availability Group (SQL Server)
at the Microsoft MSDN Library.

2. Perform the upgrade on both nodes. Wait until the upgrade finishes successfully and then add
the HP Insight Control performance management (PMP_V5_0) and HP infrastructure orchestration
(hpio, oo and HPMOEMetering) databases, as applicable, back to the Always On Availability
Group using the Add database wizard in the Availability Group. For more information,
see Add a Database to an Availability Group (SQL Server) at the Microsoft MSDN Library.

Minor issues

Importing certificates created using the Create Certificate Signing Request feature will not work
If you use the appliance to generate a certificate signing request and sign the certificate, and then
try to upload the signed certificate, the upload will fail with a No private key error.
Suggested action
Create the certificate entirely off the appliance. Use an external CA signed certificate that is
generated without using the appliance Create Certificate Signing Request feature, and upload that
certificate.

Backup files with customized names will not be displayed in the restore UI
When a backup is created, the name of the backup file has a very specific format. If the name of
the backup file is changed to something other than the default format, and then that file is uploaded
to the appliance as part of a restore, the uploaded file will not be visible in the UI.
Suggested action
To ensure successful restore operations, do not change the name of the downloaded backup file.

Linux installation may time out
If you are installing a large number of RPMs as part of your Linux installation, the Build Plan may
time out on the Monitor Installation step because nothing is written to the installation log
for an extended period of time, while the RPMs are installed.
Suggested action
Increase the time the Monitor Installation step waits for log activity as follows:
1. Make a copy of the Build Plan.
2. Edit your copy of the Build Plan.
3. Modify the parameters of the Monitor Installation step by adding a number after the

log file name, which indicates the number of polls the step takes before timing out. The default
is 200, so increasing to 400 or more is recommended. Here is an example of the parameters
in a Red Hat installation: tmp/anaconda.log 400

4. Retry the installation with the new Build Plan.
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CORBA COMM_FAILURE occurs intermittently during appliance use (UI or CLI)
During normal use of the appliance, a CORBA error may occur. The error looks similar to this: An
unexpected Server Automation error occurred: CORBA COMM_FAILURE
1398079691 Maybe; nested exception is: org.omg.CORBA.COMM_FAILURE:
vmcid: SUN minor code: 203 completed:

Suggested action
The error is benign and it clears up on the next automatic page refresh. If it does not clear
automatically, refresh your browser window. If the issue occurs during a REST CLI call, then retry
the call.

Multiple issues when assigning custom attributes to the device groups
There are some minor issues affecting inheritance when assigning custom attributes to the device
groups.
Suggested action
Avoid assigning custom attributes to the device groups.

Backup Administrator gets stuck on Activity page
When a backup administrator tries to access the Activity page, you get a popup message:
The login session has been lost.

When you click OK it comes back to the same popup.
Suggested action
To resolve this issue, close the browser.

Stop backup option does not stop the backup process
After starting a backup of the server provisioning appliance, and clicking on Stop backup displays
the following error message:
Unable to locate the item you requested.
Suggested action
The backup cannot be stopped from the UI. The backup procedure must run to completion.

Multiple copies of some scripts exist in the appliance
When viewing the list of scripts on the appliance, you will notice that some scripts appear twice
in the list. To avoid possible future problems when the duplicates are removed in an update, always
be sure to select the first instance of these scripts:

• Prevent WIM File Overwrite

• Remap Windows Drives

• Unmap Network Drive

• Validate Custom Attributes

• Create Windows System Drive
and the second instance of the

• Validate ImageX Package Contents script
Suggested action
To verify that you have selected the proper script for your build plan, open the build plan and click
on the link that is the name of the script in question. Then, look at the details for that script. The
version of that script should NOT be "1".
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Add server action may produce two server entries if deploying to blade servers in an enclosure
with Virtual Connect
If using Insight Control server provisioning to deploy to blade servers in an enclosure with Virtual
Connect, two server entries may be produced when using the Add server function. One is the
normal server entry, and one looks like ILOHOST_X.X.X.X. This occurs because a Virtual Connect
profile is not fully applied to the server until it is booted at least once, and the Add server operation
queries the iLO before that first boot happens.
Suggested action
To correct the problem when it happens, delete the server entry with the name ILOHOST_X.X.X.X
once the second server entry appears.
To avoid the problem, choose one of the two following actions:

• Add the server to the appliance by PXE booting the server, rather than using the Add server
action. Servers discovered via PXE booting have their iLO added automatically after the server
boots, so the profile is applied before discovery. See the HP Insight Control Server Provisioning
7.4 Administrator Guide chapter on Adding servers for more information.

• After applying the server profile, power on the server, wait for it to complete its power on self
test, and select Add server. This way, the profile is applied before the iLO is queried.

An error may occur during a Red Hat Enterprise Linux installation if installing RHEL 6.3 or 6.4 on
a server with more than one disk
When you attempt to install Red Hat 6.3 or 6.4 on a server with more than one disk on which the
Erase Server Build Plan was previously run, the following error may appear on the target server’s
console during the installation process:
This device may need to be reinitialized. REINITIALIZING WILL CAUSE ALL
DATA TO BE LOST!

This error occurs because the Erase Server Build Plan erased all data from the disks and the Red
Hat installer cannot determine the proper formatting.
Suggested action
Add zerombr to your kickstart file. See the Red Hat documentation for information about
zerombr before using it, so you can familiarize yourself with what it does.

Auto Registration of iLO during Insight Control server provisioning fails due to Remote exception
using WinPE
During the Deploying operating system step of a Matrix service request, the automatic iLO
registration process may, on rare occasions, produce an error. When this happens, the OS Build
Plan that is run against that server will fail on the Check iLO service step and the server will be
placed into the maintenance pool.
To verify if the server encountered this problem, check the server provisioning job logs to see if
both of the following failures occurred:

• The OS Build Plan failed at the Check iLO service step

• The iLO registration job failed
Suggested action
Put the server back into the available pool and try again by doing the following:

• Follow the steps as indicated in the section “Manual-clean-up process (physical)” in the HP
Matrix Operating Environment Infrastructure Orchestration User Guide.

• Re-run the Matrix infrastructure orchestration create service request.
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Japanese Smart Components from SPP are not removed during Windows image capture.
When capturing Windows images, any ProLiant utilities on that system are removed as part of the
system depersonalization. The Build Plan step Uninstall HP ProLiant Utilities is supposed to perform
this work automatically for English and Japanese OSs, but this step does not work properly on
Japanese OSs.
Suggested action
On Japanese systems, either uninstall the agents manually before capturing, or create a script to
uninstall the agents and add it to your Build Plan. Do not write the script in VBscript, as it cannot
process the UTF-8 characters properly.

ProLiant HW - Fibre Channel HBA Display Configuration Build Plan fails to capture Emulex card
details on a Gen9 server
The Build Plan exits with the following message: Errors from step 6 'Configure Fibre
Channel HBA Boot Device': No Emulex or QLogic HBAs found .
Suggested action
You can view the HBA configuration interactively from the server console or using another tool that
can manage HBAs like Matrix OE or Virtual Connect.

HP Matrix Operating Environment software
For complete release notes for the HP Matrix Operating Environment software, see the HP Matrix
Operating Environment 7.5 Release Notes.

Limitations

HP IO Accelerators limited support
HP IO Accelerators are supported in the Matrix Operating Environment with limitations. The
hypervisor version and Virtual Connect modules need to support the particular HP IO
Accelerator. Matrix OE will not provision the hypervisor host to use the HP IO Accelerators (the
installation and configuration of the hypervisor using these accelerators would be independent of
Matrix OE). Matrix OE can be used to provision VMs to the hypervisor host. For information on
HP IO Accelerators, see http://h18004.www1.hp.com/products/storageworks/io_accelerator/
index.html. Two white papers are available online that describe the setup and scenarios for using
HP IO Accelerators. You can locate the Insight Management and HP IO Accelerators (ioTurbine
version 2.0.3.1) – Supported Environments and Scenarios White Paper and the Insight Management
and HP IO Accelerators (ioTurbine version 2.1) – Supported Environments and Scenarios White
Paper at the HP Enterprise Information Library.

Managing Microsoft Windows servers without OpenSSH installed
Even though the product documentation states that OpenSSH is required, Matrix OE supports
Microsoft Windows environments not running OpenSSH. However, for Microsoft Windows systems
without OpenSSH, there are several limitations with agent installation and troubleshooting.
For details on using Matrix OE with Microsoft Windows systems not running OpenSSH, see the
HP Matrix Operating Environment 7.5 software without OpenSSH on HP ProLiant and Integrity
Servers Running Microsoft Windows white paper, available at:
http://www.hp.com/go/insightmanagement/docs

Configuring Matrix OE with a remote Microsoft SQL Server database
Since Matrix OE uses Windows Single Sign On to connect to the SQL Server database, the
credentials associated with the user account executing a command or service are also used to
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connect to the remote database. Therefore, user accounts that execute Matrix OE software and
access the database must satisfy the following conditions:

• The user credentials specified for CMS access and database access during installation must
match, and be trusted domain credentials available to both the CMS and database systems.

• The user credentials specified during installation for database access must have “Create
Database“ access permissions. The user must have “write” access to the log files and
“read/write” access after installation.

If you run a CLI command that requires database access as a user that is not a domain user or
does not have access permission on the remote database, the command fails.

Using Operations Orchestration in Matrix OE
A version of HP Operations Orchestration (OO) that is licensed for limited use is included with
Matrix OE. For more information, see the HP Matrix Operating Environment Infrastructure
Orchestration User Guide at: http://www.hp.com/go/matrixoe/docs

Pointing a remote OO Studio installation to OO Central installed on the CMS
A “Failed Login” error message may appear when logging in to an instance of OO Studio 9.x
that points to a remote repository, such as OO Central 9.x installed on the CMS.
Suggested action
1. Back up the rc_keystore file on the CMS.
2. Copy the rc_keystore file installed on the CMS at C:\Program Files\HP\Operations

Orchestration\Central\conf\rc_keystore.
3. Paste the rc_keystore file on the remote OO Studio system at C:\Program Files\HP\

Operations Orchestration\Studio\conf\rc_keystore.
4. Restart OO Studio.

For information and support on Online Guest Migration feature
For more information and support on Online Guest Migration of VM guests between servers running
Intel Itanium 9300 and Intel Itanium 9500 under the Modify menu from the Integrity Virtual Server
Manager 6.3, see the HPUX SMH - Integrity Virtual Server Manager 6.3 online help.

HP Capacity Advisor

Limitations

Capacity Advisor provides support for the HP ProLiant WS460c workstations
Capacity Advisor is able to collect historical data from HP ProLiant WS460c after following the
steps described in the How to license HP ProLiant WS460c for Capacity Advisor white paper
located at the HP Enterprise Information Library.

Capacity Advisor Scenario Editor limitations for VSP 6.1 and 6.2 hosts
In the Scenario Editor, the only VSP systems available are VM hosts that are only hosting VMs as
shown in the table below. In the Capacity Analysis dashboard, the only VSP systems available are
VM guest and vPars.

Available to Capacity Advisor Scenario EditorSystem

YesVSP Hosts that only host VMs

NoVSP Hosts that host VPARs
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Available to Capacity Advisor Scenario EditorSystem

No1VSP VM guests

NoVSP vPar guests
1 VM guests are not individually available to the Scenario Editor. Adding a VSP Host to a Scenario Editor will also add
all VM guests that are hosted by the VSP Host.

Capacity Advisor does not support collecting data from KVM VMs
Capacity Advisor supports Linux servers, but does not support collecting data from KVM VMs
running on a Linux server. If a KVM host is added to HP SIM and licensed to Matrix Operating
Environment, then Capacity Advisor collects data from the KVM host. In the Profile Viewer, the
utilization data of a KVM host displays but there is not a drop-down menu to view its VMs. In the
Scenario Editor, a KVM host is displayed as a hypervisor with no VMs so it appears as an idle
host. A KVM host is not visible in the Capacity Analysis Dashboard.

Capacity Advisor limitations with VMware SRM
With configurations that contain two CMSs, manual steps must be taken to capture the data
collected while running on the secondary site and then to merge it with the data on the primary
site. There are documented procedures available to minimize and potentially eliminate this from
happening. For more information on these procedures, see the Matrix Co-Existence with VMware
vCenter Site Recovery Management (SRM) white paper available at http://www.hp.com/go/
matrixoe/docs.

Capacity Advisor limitations with Hyper-V Replica
When DHCP is enabled, replicated VM in Replica site gets its IP address from DHCP which is
different from its IP address in Primary site. In such a situation, Replica VM should be manually
discovered with new IP address (DHCP assigned) in HP SIM. After this step, Replica VM works
fine with CapAd.
When DHCP is disabled and static IP address is assigned to VM in Primary site, Replica VM gets
the same IP address and is discovered automatically without any issue in HP SIM and works fine
with CapAd.

Minor issue

Capacity Advisor does not recognize a new OS installed on a managed node
After installing a new OS on a node previously discovered and licensed for Matrix OE, Capacity
Advisor does not update the current OS information, if it has already started collecting data. To
resolve this issue:
1. Export the profile.txt and execute the following commands at the command prompt:

cd C:\Program Files\HP\Virtual Server Environment\bin

capprofile -x nameofSystem > nameofSytem.txt

2. Modify the file nameofSytem.txt by opening the saved file and editing the following fields:
OS and OSName

WINNT – Windows, Hyper-V

LINUX - Linux

HYPERVISOR - ESX

HPUX – HP-UX

OPENVMS - OpenVMS
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3. Import profile.txt and execute the following commands at the command prompt:
cd C:\Program Files\HP\Virtual Server Environment\bin

capprofile -i -o -S nameofSystem nameofSystem.txt

4. Delete the system in HP SIM by performing the following tasks:
a. In System and Event Collections in the HP SIM console, select All System.
b. Select the targeted system and click Delete.

5. Remove the profile by executing the following commands at the command prompt:
cd C:\Program Files\HP\Virtual Server Environment\bin

capprofile -r nameofSystem

6. Rediscover the system in HP SIM.

HP Matrix Operating Environment infrastructure orchestration

Limitations

Domain name discrepancies result in Matrix infrastructure orchestration VM hosts listed in the
Unassigned server pool and failure to provision services to the host
If the Active Directory Domain name and DNS name of a VM Host (ESXi, Hyper-V or Integrity) do
not match, VMM (Insight Control virtual machine management) will show the hostname (i.e. FQDN)
as the DNS Name with the domain name appended. Matrix infrastructure orchestration will list
the VM Host in the Unassigned server pool and will fail to provision services to the VM Host.
Suggested action
To resolve this issue, change the name in AD or DNS name, so that both names are the same. The
VM Host will then appear in the appropriate server pool. An administrator can also manually move
the VM Host from the Unassigned pool to the appropriate pool. The service provisioning request
can then be repeated and can use the VM Host as appropriate.

SCVMM shows duplicate VM entries in the SCVMM console
While associating VM with Logical switch on SCVMM 2012 SP1 and SCVMM 2012 R2, SCVMM
console creates two VMs with same name and pointing to same VM files.
This is a SCVMM console issue.
Suggested action
Ignore such duplicate instances created in SCVMM consoles. The Matrix Operating Environment
shows only one correct instance.

SCVMM console will show refresh VM task in the logs folder
SCVMM console shows some number of refresh VM task in the logs folder. Sometimes in VMM
you will notice difference in returning instances from WMI and powershell.
Due to such discrepancies, VMM calls refresh VM task explicitly in both the places to maintain the
consistency.
Suggested action
Ignore the refresh VM tasks in the SCVMM console.

Hyper-V NIC teaming enabled VM on Hyper-V 2012 R2 with not selecting “Allow management
operating system to share this network adapter” as part of Virtual Switch of NIC teaming fails to
collect the PERF data for the network
If you try to create a virtual switch of NIC teaming, it configures adapter with not selecting Allow
management operating system to share this network adapter. VMM always collects the network
perf data.
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Suggested action
It is a Microsoft related issue, where WMI does not create WMI instance if you do not select the
Allow management operating system to share this network adapter option. While creating the
virtual switch, always ensure to select the option Allow management operating system to share
this network adapter.

Dual DNS IP and suffixes entries are seen for Linux guest
If you specify DNS suffix to the Linux VM residing on VMware host, it fails to set the domain name.
It sets the DNS suffix as the domain name.
It is a VMware related issue.
Suggested action
Do not specify the DNS suffix while defining the Matrix infrastructure orchestration network.
Manually set the DNS suffix for the Linux VM residing on the VMware host.

High Availability Hyper-V VMs with pass-through RDM cluster disk considerations
High Availability Hyper-V VMs with non-clustered RDM disks and non-High Availability cluster
RDM disks are not supported in this release and prior releases. Matrix OE supports only High
Availability Hyper-V VMs with clustered RDM disks and non-High Availability with non-clustered
RDM disks.
Suggested action
Avoid using High Availability Hyper-V VMs with non-clustered RDM disks and non-High Availability
with clustered RDM disks with Matrix OE.

Migrating from one CMS to another using Operations Orchestration
If you are using Matrix with Operations Orchestration (OO) workflows, you may experience
workflow failures after migrating from one CMS to another CMS. These failures have two sets of
possible causes and actions:
1. Duplication of values

The Run ID values from one CMS are not migrated via the DMT (Data Migration Tool) when
moving from one CMS to another. The new CMS will start the values over rather than resuming
from a previous value, resulting in duplicate values.
Suggested action
Run the SQL script provided in the Data Migration of an Existing Microsoft Windows CMS to
a New Insight Management 7.4.1System white paper available at http://www.hp.com/go/
matrixoe/docs.

2. Lack of necessary information
The logic of the OO workflow is dependent on remote information or some state information
that is not available or appropriate on the new CMS. If you are using the Custom Hostnames
feature, for example, and have modified the sample OO workflows to support your specific
server naming strategy, the migration tool will not handle workflow-customized server-naming
strategies. If your workflow stored state information on the CMS, it was probably not migrated
to the new CMS.
Suggested action
Modify the OO workflows on the new CMS as appropriate. You must ensure that the workflows
and any external resources are manually updated to run properly on the new CMS (for
example, to provide necessary connectivity information to a remote server with a database
of custom hostnames, or to provide suitable state information based on previous work done
on the prior CMS). For more information, see the Data Migration of an Existing Microsoft
Windows CMS to a New Insight Management 7.4.1 System white paper available at http://
www.hp.com/go/matrixoe/docs.
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IO/OO Load Balancer workflows not able to process large HAProxy configuration requests
The Create Logical Load Balancer Groups workflow targeting the Load Balancer HAProxy may
fail with the following error message:
The execution of the workflow Create a Logical Load Balancer Groups has
failed.

If this error message appears, the HAProxy configuration file is too big and the infrastructure
orchestration/OO Load Balancer workflows are not able to process this request. To create many
services that use this load balancer, HP recommends that you use the F5 BIG-IP Load Balancer.
For more information, see the F5 - BIG-IP Local Traffic Manager website at http://
h17007.www1.hp.com/one/alliance/f5/big-ip.htm?jumpid=reg_r1002_usen_c-001_title_r0001.

VM disks using different datastores
Designer allows boot and data disks connected to Virtual Server Groups to use different storage
volume names. This feature allows VM boot and data disks to be allocated to different storage
volumes with the following limitations:

• Integrity VM disks must all use the same storage volume names or be blank.

• Cloud server disks do not support storage volume names and must be blank.

• Hyper-V VM Linked Clone disks must have the same storage volume names or be blank.
Hyper-V VM Linked Clone cannot be spread across different datastores.

• Microsoft does not support VM Linked Clone using multiple datastores.

NOTE: VM logical servers manually created from Matrix OE visualization can also specify VM
disks on different data stores.

Cross-technology logical servers are not supported by infrastructure orchestration
Only logical servers created or imported in Matrix OE logical server management, using
Create→Logical Server or Tools→Logical Servers→Import, can be moved from physical to virtual
or virtual to physical (however, to move from virtual to physical you must first move from physical
to virtual). A logical server created in infrastructure orchestration (by deploying a service template)
cannot be managed as a cross-technology logical server. For example, if a physical logical server
is created in infrastructure orchestration, it cannot be moved to a VM using logical server
management. Similarly, if a virtual logical server is created in infrastructure orchestration, it cannot
be moved to a server with VC using logical server management.
For more information about cross-technology logical servers, see the HP Matrix Operating
Environment Recovery Management User Guide at the Matrix OE Information Library.

Multi-initiator NPIV support on Integrity server blades
Multi-initiator NPIV features used by Matrix OE and HP Virtual Connect Enterprise Manager (VCEM)
are supported on Integrity server blades using:
• QLogic FC (Fibre Channel) controllers with the HP-UX 11i v3 Update 8 (March 2011) and

later release.
• Emulex FC controllers with HP-UX 11i v3 March 2013 update and later release.
Suggested action
On Integrity server blades with Emulex controllers and/or versions of HP-UX earlier than 11i v3
March 2013 update release, create a single storage pool entry that combines a boot volume and
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the data volumes intended to be allocated to a single physical server. You can do this in one of
the following ways:

• Pre-provision any number of these composite storage pool entries to enable fully automated
allocation of SAN volumes to physical servers.

• Pre-provision storage pool entries with only boot volumes. An automated provisioning request
pauses after the operating system is deployed if the infrastructure service template specifies
data disks. You can modify the storage pool entry allocated to the server to add data volumes,
and then continue the request.

Installing the Microsoft Sysprep tool for post-installation customization of Windows 2003 guests
on Hyper-V
The Microsoft System Preparation (Sysprep) tool, required for customization of Windows 2003
guests on Hyper-V, is not retained on the CMS after upgrading from previous versions of Insight
Management. Without these tools, customization of Windows 2003 guests on Hyper-V fails.
Installation of the Sysprep tool is not required for customization of Windows 2008 and higher VM
guests.
Suggested action
After installing or upgrading Insight Management, install the Microsoft Sysprep tool on the CMS
in the C:\Program Files\HP\Insight Control virtual machine management\
Sysprep\2003 folder.

CSV does not appear after Hyper-V VM provisioning with HA enabled
If you use Matrix infrastructure orchestration to create and deploy a virtual provisioning template
on a Hyper-V VM host with the high availability (HA) option enabled, and then view the VM in
the Failover Cluster Manager on the Hyper-V host, the cluster shared volume (CSV) is not displayed
in the provisioned VM information.
However, if you manually deploy the VM using the Microsoft Hyper-V Manager on the Hyper-V
VM host, the Failover Cluster Manager correctly displays the disk resource and the VM resources
created.
Suggested action
No action is needed. The HA VM disk was created correctly by infrastructure orchestration on the
CSV.

CSV is not correctly recognized unless all VM hosts in the Hyper-V cluster are registered in Insight
Control virtualization
When only one VM Host in a Hyper-V cluster is managed by Insight Control virtual machine
management, the following areas are impacted:

• Matrix OE infrastructure orchestration — IO treats a CSV as a cluster disk, and allocates only
one VM to the cluster disk. When trying to deploy multiple VMs, the following error appears:
Provisioning request has paused. Modify storage volumes on VM Hosts
to satisfy the logical disk requirements. An IO Administrator has
been notified.

• Matrix OE visualization with logical server management capabilities — The CSV and cluster
disk are only available on the VM Host if the registered VM Host ID is the VM Host owner.
Otherwise, the VM Host is placed on the Rejected List and an error indicates that the storage
is not available on the VM Host.

Suggested action
Add all VM Hosts in the Hyper-V cluster to Matrix OE infrastructure orchestration and register them
with Insight Control virtual machine management as VM Hosts. The VM Hosts can be left in the
Unassigned pool, or they can be used as regular VM Hosts within IO.
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Cannot provision a server group on Hyper-V R1 with linked clone and HA enabled
If you attempt to provision a template containing multiple HA-enabled linked clones on a Hyper-V
R1 server, or you attempt to add a server to a server group with a single HA-enabled linked clone
on a Hyper-V R1 cluster disk, the request pauses indefinitely for storage provisioning. A linked
clone group must be provisioned on a single datastore, but only one HA VM can be provisioned
to a Hyper-V cluster disk.
Suggested action 1
1. Cancel the Create or Add Server request.
2. Modify the template to remove the HA requirement, or

Modify the template to deselect linked clones and add a cluster disk for each VM.
3. Resubmit the Create request, or

For the Add Server request, delete the existing service and recreate it with the updated template.
Migrate data from the existing service to the new service before deleting the existing service.

Suggested action 2
Upgrade to Hyper-V R2, and specify a CSV instead of a cluster disk in the template.

Registering Microsoft SCVMM on a single CMS
As part of the registration of Microsoft System Center Virtual Machine Manager (SCVMM), the
web service component is copied from the CMS to the SCVMM host, enabling communication
between the two servers. As a result, SCVMM can be registered on only one CMS. In a federated
CMS configuration, each CMS requires a separate SCVMM host to manage Hyper-V hosts through
SCVMM. This requirement differs from VMware VCenter which can be registered to more than
one CMS. For more information about registering SCVMM, see the HP Matrix Operating
Environment Infrastructure Orchestration User Guide available at:
http://www.hp.com/go/matrixoe/docs.

Browsing to the user interface requires the default HP SIM port
HP SIM is installed with a default port of 50000 in the JBoss container. Browsing to the Matrix
infrastructure orchestration user interfaces, such as infrastructure orchestration designer, requires
this port.
Suggested action
Do not modify the HP SIM default port of 50000 in the JBoss container.

OS Customization may fail when an IO template based on ESXi Linux VM template is customized
to use a Hyper-V Windows VM template
HP SIM is used to create a Hyper-V VM template from a powered off Hyper-V hosted Windows
VM. If a customizable Matrix infrastructure orchestration template that is based on an ESX Linux
VM template is later customized to use the Hyper-V VM template, service provisioning fails at the
OS customization step. Note also, that the software inventory listing for the Hyper-V VM template
shows empty OS Name and OS Type fields.
Suggested action
Prior to using the SIM Deploy→Virtual Machine→Templates→Create Virtual Machine Template…
command to create the Hyper-V VM template:

• Ensure that the Hyper-V hosted Windows VM is powered on.

• Ensure that Microsoft Hyper-V Integration Services is installed and running.
The resulting Hyper-V VM template will have a non-empty OS Name and OS Type listed in the
software inventory and can be successfully provisioned.
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ESXi Linux VM customization fails when two network adapters have different DNS suffixes
If you create an EXSi Linux VM with two network adapters and those adapters have different DNS
suffixes, the server will always join the AD Domain using the suffix of the primary network adapter.
Suggested action
Ensure the primary network adapter has appropriate DNS suffix (or have both network adapters
use the same DNS suffix).

VM network state is disconnected after ESXi Virtual provisioning
If the ESXi VM used to create a VM template has a network adapter with no connectivity, any VM
created from that template will not have network connectivity. This is a VMware
related issue.
Suggested action
Ensure the network adapters for the VM are connected before creating the VM template.

Matrix API and CLI add network interface operation does not support customization options
In version 8 of the Matrix API the addNetworkInterfaceToLogicalServerGroup operation
defines an optional customizeNetwork parameter. This capability currently is not supported.
The parameter should be omitted or a value of false specified. Specifying a value of true causes
the request to fail.
Suggested action
The CLI addnic logicalservergroup operation defines corresponding
-customize-operating-system and -O options. These options must not be used as both
causes the request to fail.

Add Floating IP Address Operation fails with CloudSystem 8.0, 8.1, and 8.1.2 servers
The Matrix infrastructure orchestration Add Floating IP address operation fails, with an
error indicating failure to allocate the IP address, when performed on servers provisioned to
CloudSystem 8.0, 8.1, or 8.1.2 resource pools.
Suggested action
Use the CloudSystem console or CLI to allocate floating IP addresses.

Enabling Matrix infrastructure orchestration provisioning support of Linux VMs on Hyper-V

NOTE: The hpio.properties value
skip.linux.on.hyperv.template.personalization allows Linux VMs on Hyper-V, but
it is deprecated. See “Skipping automated OS customization” (page 53) for information on allowing
Linux VMs on Hyper-V.

Skipping automated OS customization

By default, after infrastructure orchestration deploys an OS to a server, it automatically customizes
(personalizes) the OS by setting the host name, IP addresses, netmask, default gateway, and other
attributes as appropriate. As of the 7.3 release, automatic OS customization can be skipped by
performing the actions noted below. These actions allow the service template architect to design
service templates that use OS images intended to be customized outside of Matrix OE, such as
when deploying Linux VMs onto Hyper-V. When the skip customization feature is used, customization
of the deployed VM is no longer performed by Matrix, and becomes the responsibility of the
architect to ensure that the VM is configured properly.
1. Select the Skip OS Customization check box

In designer, navigate to Configure Server Group→Software→1. Select Operating System.
Select the Skip OS Customization check box.
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NOTE: The per-server-group Skip OS Customization check box is enabled when
allow.skip.os.customization = true in hpio.properties.
If you do not see the Skip OS Customization check box, edit the hpio.properties file to
set allow.skip.os.customization = true.

2. Ensure appropriate OS customization is done (perhaps via an Operations Orchestration
workflow attached to the service template).

Selecting fabrics when auto-generating storage pool entries through Matrix infrastructure
orchestration
When auto-generating storage pool entries from Matrix infrastructure orchestration, if more than
a single pair of fabrics exist, Matrix infrastructure orchestration determines which pair to use.
Suggested action
To set the preferred list of fabrics to use during the auto-generation of storage pool entries, edit
the lsa.properties file and add the
SPM_AUTO_PREFERRED_FABRICS=FabricA,FabricB,FabricC:FabricD propertywhere
FabricA, FabricB, and so on are replaced with user-defined fabric names.
Fabrics separated by a colon (:) are redundant pairings.
If the storage is not redundant, Matrix infrastructure orchestration searches for storage pool entries
using the specified fabrics in the order listed. If the storage is redundant, Matrix infrastructure
orchestration only searches for storage pool entries using the specified redundant fabric pairings
in the order listed.
In the above example:
• For non-redundant storage, IO searches FabricA, FabricB, FabricC and FabricD in order.

• For redundant storage, IO searches the FabricC/FabricD pairing.

• If no storage pool entry is found after searching the fabrics defined in this list, IO searches all
known fabrics based on the pre-defined rules.

NOTE: The fabrics listed in this property are used by all auto-generation of storage pool entries
from Matrix infrastructure orchestration on the CMS. This property cannot be configured at the
user or organization level.

Matrix OE does not support configurations other than Full Stacking
Virtual Connect 4.30 and later support alternatives to Full Stacking mode, but Matrix OE does not
support such configurations. When a Virtual Connect Domain Group is configured to use a mode
other than Full Stacking, such as Horizontal Stacking or Primary Slice stacking, the following occur:

• Matrix OE lists the associated logical servers as inoperable.

• The portability group is not visible in Matrix OE.
To change the VC Stacking Mode:
1. Turn on maintenance mode for the Virtual Connect Domain Group.
2. Change the VC Stacking Mode to Full Stacking.
3. Turn off maintenance mode for the Virtual Connect Domain Group.
Suggested action
Check if the VC Domain Group is configured with Full Stacking. Change the VC Stacking Mode
to Full Stacking, if it is configured as Horizontal Stacking or Primary Slice Stacking.
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RHEL 7 Customization not supported
RHEL 7 can only be customized with the enhanced server customization feature when using Insight
Control server provisioning.

Growth of virtual or physical disks from Matrix is not supported for Integrity blades and HP-UX
vPars and Integrity VMs
The ability to grow the size of a virtual or physical disk from Matrix (using Matrix infrastructure
orchestration or Matrix OE visualization with logical server management is not supported for
Integrity blades and HP-UX vPars and Integrity VMs.

Ability to add or remove networks from Integrity blades and HP-UX vPars and Integrity VMs is not
supported
Addition or deletion of networks to or from server groups of already provisioned services using
GUI, CLI or API is not supported for Integrity blades or HP-UX vPars and Integrity VMs.

Major issues

VCM server profile assignment may fail for Gen9 servers
HP Matrix OE infrastructure orchestration service provisioning fails when attempting to assign a
VCEM profile to a Gen9 server. The VCEM log indicates an error of the following form:
Error during Assign server profile <profile> in domain <domain>.
Details: VCEM received an unexpected error from the VC Manager.

This issue can occur when the EV store becomes inconsistent during server reboot, preventing
successful assignment of a VCEM profile.
Suggested action
If this problem occurs, either physically reset the server or use the Onboard Administrator to reset
the server and then reapply the profile. If the problem persists, clear the server BIOS settings. To
avoid this problem, change the value of the GRACEFUL_POWEROFF property from false to true in
the Virtual Server Environment/conf/lsa.properties file.

Gen8 (and later) servers are booting using PXE rather than HP Intelligent Provisioning
The deployment server supports use of HP Intelligent Provisioning but PXE boot is being used.
This issue occurs when the Matrix OE infrastructure orchestration
hp.intelligent.provisioning.boot property is set to false in the hpio.properties
file.
Suggested action
Set the hp.intelligent.provisioning.boot property to true.
Additionally, ensure that the SAplugin.jar located in the Systems Insight Manager\lib
directory is from SAAL-53351-setup.exe or later. For further information see the readme.txt
file located at Systems Insight Manager\bin\sa\readme.txt on the CMS.

Null Pointer Exception Reported when OO Workflow Sends Email
A Null pointer exception is reported when an Operations Orchestration workflow attempts to send
email.
This issue occurs when the HpioSmtpCredentials System Account user name field has an entry,
but the password field does not. This may be the case when the SMTP server does not require
authentication.
Suggested action
Ensure that both fields have values, specifying dummy data if necessary; these fields are not used
when the SMTP server does not require authentication.
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After upgrade from 7.4 to 7.4.1 the Lifecycle operations in the DL service fails
The esa.oo.admin.password value is not correctly migrated during CMS upgrade from 7.4
to 7.4.1. Thus, after the CMS upgrade from 7.4 to 7.4.1, the Lifecycle operations in the DL service
fails.
Suggested action
During an upgrade, Matrix Operating Environment properties files from an earlier release are
replaced by new properties files for the 7.4 Update 1 release. Change the following entries to
identify different behavior for upgrade to full release and intermediate patches:

• For upgrade to minor version:
C:\Program Files\HP\Matrix infrastructure Orchestration\conf\
blade_models.properties

C:\Program Files\HP\Virtual Server Environment\conf\esa.properties

C:\Program Files\HP\Virtual Server Environment\conf\lsa\
hp_lsa_service.conf

C:\Program Files\HP\Virtual Server Environment\conf\lsa\
lsa.properties

C:\Program Files\HP\Virtual Server Environment\conf\lsa\
lsaclient.properties

C:\Program Files\HP\Virtual Server Environment\conf\lsa\vc\
vcController.properties

C:\Program Files\HP\Virtual Server Environment\conf\lsa\vmm\
vmmController.properties

C:\Program Files\HP\Virtual Server Environment\conf\lsa\storage\
storageController.properties

Linked clone provisioning of a VM template containing shared disks does not succeed
During ESX server provisioning, errors similar to the following are displayed:
Error taking a snapshot on virtual Logical Server nnnnn. Virtual machine
is configured to use a device that prevents the snapshot operation:
Device is a SCSI controller engaged in bus-sharing.

The VM template created from an infrastructure orchestration template specifies linked clone servers
and deploys software as an embedded shared disk. This combination is not supported.
Suggested action 1
Edit the template in designer and clear Deploy as Linked Servers.
Suggested action 2
Select other software to deploy without an embedded shared disk, and then retry the Create Service
operation.

Provisioning of Matrix OE service fails during customization
Provisioning of Matrix services can fail during customization if Insight Control server provisioning
or SA deployment is attempting to join the server to an Active Directory or performing NIC teaming
during the OS installation. Doing so will cause the Matrix post-install customization step to fail
with an error stating Error customizing Logical Server <Logical server name>
realized by <target UUID>.

Suggested action
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Matrix OE environments can have the newly provisioned server join the domain or perform NIC
teaming by using enahced server customization. For additional information on this, see the HP
Matrix Operating Environment Infrastructure Orchestration User Guide.

NOTE: HP does not recommend using an OO workflow to join a newly provisioned server to
the domain as it requires adding all computers as trusted hosts.

Ignite fails to provision, if the SAN is configured with Multiple path
HP-UX deployment with Ignite may fail if multiple SAN paths are configured in active-passive mode.
The installation of HP-UX operating system with physical servers might fail with the following error
message: The path to the root device
(0/0/0/5/0/0/0.0x207000c0ffda4ee1.0x4070000000000000) does not support boot. You
must choose a bootable path to the root disk. Note that virtualized FibreChannel paths are not
bootable.
This issue might be seen on environments, which have multiple SAN paths configured to the physical
blade, and the paths are configured in active-passive mode.
Suggested action
Switch the multipath configuration to active-active mode, thus making all the SAN paths in active
mode.

Minor issues

Registration of SCVMM 2012 SP1 and SCVMM 2012 R2 server fails on a CMS
Registration of SCVMM 2012 SP1 and SCVMM 2012 R2 server fails sometimes. This is an
intermittent issue and observed several times on a CMS configured with Microsoft Windows Server
2012/ Microsoft Windows Server 2012 R2 operating system.
Suggested action 1
To solve this issue, retry to register SCVMM server.
Suggested action 2
Add a parameter SCVMM_Retries in hpvmm.conf file (located in <IMinstallation>\
Insight Control virtual machine management\bin) and set the value to more than
5. Restart virtual machine management service and try registration again.
Suggested action 3
If it still fails to register SCVMM, then perform the following steps:
1. Check if the HP Matrix SCVMM Web Service is installed on the SCVMM server.
2. If the HP Matrix SCVMMWeb Service is not installed, copy the ScvmmWS2012.msi file from

<IM installation>\Insight Control virtual machine management\bin to
the target SCVMM server.

3. Manually install the HP Matrix SCVMM Web Service.
4. Run the HP Matrix SCVMM Web Service on the SCVMM server and re-register the SCVMM

server.

Guest having differential disk fails
Guest having differential disk fails during the transport operation, customization, and control
operation. The APIs that fetch information about disks display incorrect details because the HP
Insight Control virtual machine management does not support differential disks.
Suggested action
To solve this issue, avoid using guest which has differential disk attached.
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SCVMM deployment fails for SCVMM template formed out of Generation 2 virtual machine
When you create a template from a Generation 2 virtual machine, by generalizing the boot disk
of VM boot disk in the process, and also copying the first boot device of the VM to the template
verbatim, the template as its first boot device as an entry does not refer to any actual boot device
for that template. This might not be a problem because when a VM is booted, it will go through
the entries in the boot order one-by-one until the VM is booted. However, when you try to create
a new VM out of this template, Insight Control virtual machine management will try to set the first
boot device of the VM to the file entry as set in the template and will fail with error text as: VMM
cannot find the device. or This device is not valid for a boot device.
Suggested action 1
After creating a template from a VM, modify the first boot device of the template to a valid device.
Suggested action 2
After the creation of VM and before taking the template, change the boot order and move up the
virtual hard disk to first place in the boot order. Then take a template from SCVMM. This will
resolve the SCVMM deployment problem for Generation 2 VMs.

Host IP address field is populated with hostname instead of IP address
Logical Switch Detail is not available for host if Insight Control virtual machine management and
SCVMM manage the host with different FQDN. If VMM manages a host with one FQDN and in
SCVMM you have added the same host with a different FQDN due to different DNS, the Logical
Switch Detail is not populated.
Suggested action
To solve this issue, ensure that VMM and SCVMM register the host with the same FQDN.

Error adding a CPU to ESXi VM without OS installed (CPU Hot Plug)
Matrix infrastructure orchestration does not allow you to add a CPU on a VM without an OS
installed.
Suggested action
To update the CPU on a running VM, you should have an operating system that supports processor
hot plug. A VM without an operating system cannot have the CPU allocation updated. Virtual
Center does not allow CPU hot plug in a VM without an OS.

Error adding a CPU to an ESXi VM with RedHat 6.4 installed (CPU Hot Plug)
An attempt to use Matrix infrastructure orchestration to increase the number of CPUs for an ESXi
VM with Redhat 6.4 fails with the error: CPU hot plug is not supported for this
virtual machine.

VMM/VMware returns CPU hot plug enable, but Enable CPU hot add only for this virtual machine
is grayed out for the VM in vSphere. VMware and vSphere are not in sync with the flag. This issue
occurs on the ESX VM of ESX5.1 host and is not observed on ESX5.5 host.
Suggested action
This works fine with VMM/VMware.

Create Service request with Insight Control server provisioning fails when deploying SLES11 SP3
OS
The installation of SLES11 SP3 hangs at 60% or fails with an exit code 6 error on the appliance
console.

• In Matrix OE, one of the following error appears on the infrastructure orchestration Requests
screen and the failed server is moved to the maintenance pool:
Failed while deploying operating system for service. Cause: Logical
Server job has failed. Logical server job completed with a failure
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status. Failure: At least one OS or software deployment has failed.
Check the Deployment Service to diagnose the details

or
Task for Logical Server has failed. Logical server job
(logicalservername_FQDN) completed with a failure status. Failure:
At least one OS or software deployment has failed

• In the Insight Control server provisioning appliance console, one of the following error appears:
Failed to integrate HP SA Agent at Step 19

or
Wait for HPSA Agent failed with exit code 6 at step 21

Suggested action
1. Perform manual cleanup, see the Manual clean-up process (physical) in the HP Matrix Operating

Environment Infrastructure Orchestration User Guide at http://www.hp.com/go/matrixoe/
docs and perform the steps Manual cleanup for HP Insight Control server provisioning.

2. Recreate the service request in Matrix infrastructure orchestration.

Create Service request with Insight Control server provisioning fails when deploying RHEL 5.9 OS
The installation of RHEL 5.9 OS fails with the following messages:

• In Matrix OE, the following error appears on the infrastructure orchestration Requests screen
and the failed server is moved to the maintenance pool:
Task for Logical Server has failed. Logical server job (ID =
logicalservername_FQDN) completed with a failure status. Failure:
At least one OS or software deployment has failed

• In the Insight Control server provisioning appliance console, the following error appears:
Monitor Installation with exit code 1 at step 19

The target server remains in LinuxPE in maintenance server mode.
Suggested action
1. Perform manual cleanup, see the Manual clean-up process (physical) in the HP Matrix Operating

Environment Infrastructure Orchestration User Guide at http://www.hp.com/go/matrixoe/
docs and perform the steps Manual cleanup for HP Insight Control server provisioning.

2. Recreate the service request in Matrix infrastructure orchestration.

Provisioning of Integrity VMs with NPIV disks with storage pool entries containing both boot and
data volumes may fail
Provisioning of Integrity VMs with NPIV disks may fail if the storage pool entry selected has both
boot and data entries. The following error appears:
Failed while deploying operating system for service <service-name>.
Cause: Logical server job (ID = <Logical-server-job-id>) completed with
a failure status. Failure: An unexpected error has occurred. Check
Alc1_0.0.log and HP SIM log files under HP SIM logs directory for
additional details

Suggested action
When creating a service from a template containing physical boot and data disks, create a separate
storage pool entry for each boot disk and a separate entry for each data disk. Do not create a
single entry for both boot and data disks.
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Provisioning errors appear on a Hyper-V cluster after a CSV disk failure
If a CSV is in a failed state (for example, if LUNs are not available or in a read-only state), Insight
Control virtual machine management cannot obtain information about the CSV. Subsequently,
operations on the Hyper-V cluster (including provisioning) fail, or all VM Hosts in the cluster are
excluded from operations.
Suggested action
1. Remove the failed CSV from the Hyper-V cluster and correct the issue that caused the failure.
2. Bring the CSV back online.
3. Manually refresh server resources in Matrix OE visualization by selecting Tools→Logical

Servers→Refresh....
4. Retry the failed operation.

NIC is not configured properly on a new VM after a successful Linux guest deployment in an
ESX/ESXi/vSphere environment
Networking may not work on a provisioned Linux VM on an ESX/ESXi/vSphere host due to a
known VMware issue that impacts all versions of Linux in an ESX/ESXi/vSphere environment.
Suggested action
To reconfigure your network on the provisioned VM, see http://kb.vmware.com/selfservice/
microsites/search.do?language=en_US&cmd=displayKC&externalId=2002767.

Setting retry parameters for BL620c G7 and BL680c G7 server blades
Matrix infrastructure orchestration may time out while waiting for the server to be recognized due
to long server post times, particularly with the BL620c G7 or BL680c G7 server blades.
Suggested action
Increase the retry parameter:
1. Edit the C:\Program Files\HP\Matrix infrastructure orchestration\conf\

hpio.properties file to set the retry.count.ares.pxe parameter to a value greater
than 30.

2. Restart the Matrix infrastructure orchestration service.

Deployment of HP-UX 11i v3 1203 or HP-UX 11i v3 1209 on an Integrity i2 or i4 server blade
using Matrix infrastructure orchestration with Ignite-UX may fail
When deploying HP-UX 11i v3 1203 or HP-UX 11i v3 1209 on a BL860c i2, BL870c i2, BL860c
i4, BL 870c i4, or BL890c i4 server blade using Matrix infrastructure orchestration with Ignite-UX,
the Create Service request may fail and the server is not provisioned. The request cannot deploy
the HP-UX OS and the following error appears:
Major,"Failed while deploying operating system for <your service name>.
Cause: Logical server job (ID = <your logical server ID>) completed
with a failure status. Failure: Deployment server does not have a record
of the target system(s).”

Suggested action
1. Erase the disk used by the target server for deployment.

a. Be sure that all hosts are in the same zone, and then perform a LUN clean-up using the
storage management server (such as EVA or 3PAR StoreServ Storage).

b. Unpresent the host associated with the vdisks and delete the vdisks.
c. Create the new vdisks with the required sizes and RAID levels and present the vdisks to

the respective hosts.
2. Deactivate the logical server associated with the target server.

a. From the HP Matrix Operating Environment menu, click Tools→HP Matrix OE Visualization.
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b. Select Logical Server from the Perspective drop-down menu.
c. Select the logical server and click Tools→Logical Servers→Deactivate....
d. Monitor the status of the task by selecting Report→Logical Server Job Status.
e. Wait for the task to complete successfully before continuing to the next step.

3. Select the deactivated logical server and click Delete→Delete Logical Server...
4. Move the target server from the IO maintenance pool to the desired server pool.

a. From the HP Matrix Operating Environment menu, click Tools→Infrastructure Orchestration.
b. Click the Servers tab and verify that the Usage column indicates that the servers are not

in use.
c. Move the servers under the maintenance pool to the desired server pool by using the

Modify Pool option.
5. Recreate the service request.

Create Service or Delete Service request for an Integrity server fails due to an EFI disk read error
A Create Service or Delete Service request for an Integrity server with an FCoE device may fail
due to an EFI disk read error. A message displays in the Matrix infrastructure orchestration Requests
screen that the request for the logical server failed.
To determine if this error is caused by an EFI disk read error, open a console window on the host
and look for a message similar to the following:
Automatic boot entry execution will start in 1 second .

Booting VC Pri. Fibre(0x5001438004C8E7B8,0x1000000000000)

Boot Failed. VC Pri. Fibre(0x5001438004C8E7B8,0x1000000000000)

Booting HP-UX Primary Boot:
0/0/0/3/0/0/2.0x5001438004c8e7b9.0x4001000000000000

Error - efi_disk_read returned (Device Error)

Suggested action
If the EFI disk read error displays in the console, clean the logical server and retry the service
request:
1. Erase the disk used by the target server for deployment.

a. Be sure that all hosts are in the same zone, and then perform a LUN clean-up using the
storage management server (such as HP P6000 Command View Software or 3PAR
StoreServ Storage).

b. Unpresent the host associated with the vdisks and delete the vdisks.
c. Create the new vdisks with the required sizes and RAID levels and present the vdisks to

the respective hosts.
2. Deactivate the logical server associated with the target server.

a. From the HP Matrix Operating Environment menu, click Tools→HP Matrix OE Visualization.
b. Select Logical Server from the Perspective drop-down menu.
c. Select the logical server and click Tools→Logical Servers→Deactivate....
d. Monitor the status of the task by selecting Report→Logical Server Job Status.
e. Wait for the task to complete successfully before continuing to the next step.

3. Select the deactivated logical server and click Delete→Delete Logical Server...
4. Move the target server from the IO maintenance pool to the desired server pool.

a. From the HP Matrix Operating Environment menu, click Tools→Infrastructure Orchestration.
b. Click the Servers tab and verify that the Usage column indicates that the servers are not

in use.
c. Move the servers under the maintenance pool to the desired server pool by using the

Modify Pool option.
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5. Recreate the service request.

Matrix infrastructure orchestration provisioning fails on Integrity BL870c i2, BL890c i2, BL870c
i4, and BL890c i4 server blades
The serverboot.physical.wait.seconds parameter in the IOinstalledDir/conf/
hpio.properties file and the INTEGRITY_POWERON_WAITTIME parameter in the
VSEinstalledDir/conf/lsa/lsa.properties file are not set correctly according to the
server blade models. The wait time specified in these parameters allows the Integrity server blade
to boot completely before infrastructure orchestration or Matrix OE logical server management
executes a power off command. Correct values are required to prevent a QLogic HBA card EFI
from being corrupted while the VC profile is written to or removed from the NVRAM.
Suggested action
1. Measure the time required for a power cycle of the Integrity blade being provisioned.

NOTE: The time varies based on the server blade model, memory size, and number of
QLogic cards. You can measure the power cycle time from the Integrity server blade remote
console using OA or VCEM.

2. Set the serverboot.physical.wait.seconds and INTEGRITY_POWERON_WAITTIME
according to the time measured in step 1.
Use the following parameters as a minimum:

• BL870c i2 and i4 server blades:

◦ serverboot.physical.wait.seconds — 540 seconds

◦ INTEGRITY_POWERON_WAITTIME — 540000 milliseconds

• BL890c i2 and i4 server blades:

◦ serverboot.physical.wait.seconds — 1080 seconds.

◦ INTEGRITY_POWERON_WAITTIME — 1080000 milliseconds.

Deleting the chargeback archive can cause the database transaction log to grow very large
Using the chargeback CLI chargeback archive databasedelete command can cause a
large number of registers to be added to the HPMOEMetering database transaction log, especially
if the date specified by the -d qualifier is a year or more. If the log grows large enough, the hard
disk on which the database is running may run out of free space.
Suggested action
Before executing chargeback archive databasedelete, consult with your database
administrator. If you have already executed the command, ask the administrator about performing
a shrink operation on the transaction log.

HP Matrix OE logical server management

Limitations

Restrictions on using cross-technology logical servers
Cross-technology logical servers can be moved between ProLiant server blades with VC to
ESX/ESXi/vSphere and back, between Integrity server blades with VC to Integrity VM or HP vPars
and back, and between servers with VC with unlike configurations. For more information, see the
HP Matrix Operating Environment Logical Server Management User Guide and the HP Matrix
Operating Environment Recovery Management User Guide at the www.hp.com/go/matrixoe/
docs.

62 Issues and suggested actions

www.hp.com/go/matrixoe/docs
www.hp.com/go/matrixoe/docs


Performing operations on a logical server running as a VM Host
Before performing any operations on a physical server running as a VM Host, be sure that all jobs
related to controlling the VM guests running on the VM host logical server are complete. Then, use
the appropriate steps in the following table to prevent VM guests and VM logical servers from
becoming inoperable.

Steps to perform for the VM host after performing the
steps on the VM guests

Steps to perform on VM guestsVM host operation you
want to perform

Power off or perform a graceful
shutdown of all VM guests.

Move the VC profile to
another server blade.

1. Unregister the VM host from Insight Control virtual
machine management. From HP SIM, select
Configure→Virtual Machine→Unregister Virtual
Machine Host…

2. Move the VM host logical server. Select
Tools→Logical Servers→Move.

3. Register the moved VM host using Insight Control
virtual machine management. From HP SIM, select
Configure→Virtual Machine→Register Virtual
Machine Host…

Shut down the VM host logical server.Power off or perform a graceful
shutdown of all VM guests.

Shut down the VM host.

Power off or perform a graceful
shutdown of all VM guests.

Power off the VC server
blade.

1. Perform a graceful shutdown of the VM host.
2. Power off the VC server blade where the VM host

logical server resides. Select Tools→Logical
Servers→Power Off....

Delete the VM host logical
server.

1. Unregister the VM host from Insight Control virtual
machine management. From HP SIM, select

• If you no longer need the VM
guests, delete them. Otherwise,

Configure→Virtual Machine→Unregister Virtual
Machine Host…

move all VM guests to a suitable
host.

2. Delete the VM host logical server. Select
Delete→Delete Logical Server....

• If you have VM guests that are
not logical servers, then use the
appropriate tools to relocate the
guests.

• If you have any inactive VM
logical servers, reactivate them
and then move them to a suitable
host.

Deactivate the VM host logical server. SelectPower off or perform a graceful
shutdown of all VM guests.

Deactivate or unassign the
VC profile. Tools→Logical Servers→Deactivate.

Power off or perform a graceful
shutdown of all VM guests.

Activate or reassign the
VC profile to a different
server blade.

1. Unregister the VM host from Insight Control virtual
machine management. From HP SIM, select
Configure→Virtual Machine→Unregister Virtual
Machine Host…

2. Activate the VM host logical server. Select
Tools→Logical Servers→Activate.

3. Register the VM host using Insight Control virtual
machine management. From HP SIM, select
Configure→Virtual Machine→Register Virtual
Machine Host…

Multiple storage volume limitations
The 7.3 release added support for VMware and Hyper-V virtual machines using multiple data
stores. The specification of storage volume names for VM disks is restricted in the following cases:

• Integrity VM disks must either specify the same storage volume name or not specify a name
at all.

• Cloud server disks must not specify a storage volume name.
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• Hyper-V VM linked clone disks must either specify the same storage volume name or not specify
a name at all.

• Microsoft does not support VM Linked Clone using multiple data stores.

Importing a Hyper-V VM with the configuration file in the default location is not supported
A Hyper-V VM with a configuration file (.xml) in the default location on the hard disk
(\ProgramData\Microsoft Windows\Hyper-V) is not supported by logical server
management. You cannot import a VM guest as a logical server if the VM configuration file is in
this location. There is a limitation in Microsoft Hyper-V that allows Insight Control virtual machine
management to re-register the VM if the configuration file is created in this directory. To prevent
issues with reactivation, logical server management checks the path and rejects any VMs with a
configuration file in the default location.

Limited support for Hyper-V CSVs created with GPT disk partitioning system
Hyper-V VM hosts configured with CSV storage with a GUID partition table (GPT) disk partitioning
system are supported with the following conditions:

• All hosts (cluster nodes) must contain the same LUN identifiers for the LUN.

• LUN identifiers must be unique in the host if the LUNs are presented from different storage
arrays.

iSCSI disk requirements for use with Hyper-V VM logical servers
To enable the selection of a specific iSCSI datastore as the storage definition during logical server
creation or modification, iSCSI disks associated with Hyper-V hosts must:
• Be a cluster disk or a shared cluster volume.

• Be online.

• Contain a volume created with a drive letter.
With these limitations, only master boot record-formatted iSCSI cluster disks are supported.

VM datastore size and configuration filename limits
When creating a VM logical server (ESX/ESXi/vSphere, Hyper-V, or Integrity VM), the maximum
datastore size that you can specify is 2048 TB (2097151 GB). Additionally, the maximum number
of allowed characters for a VM configuration filename is 255. If you specify a size larger than the
maximum, a warning is logged and the entry is ignored.
VM technologies have individual configuration limits that may limit the VM disk size.

Hyper-V VM imported as a logical server may require a SCSI controller driver
If a Generation 1 Hyper-V VM is created outside of Matrix OE and imported as a logical server,
it is possible that the boot disk controller type is SCSI. In this case, you must install the SCSI controller
driver to allow installation of the operating system. This is not necessary for Generation 2 VMs
which include the SCSI drivers by default.
If a Hyper-V VM logical server is created with Matrix OE visualization, the boot disk is created
with the default disk type for the appropriate VM Version (IDE for Generation 1, or SCSI for
Generation 2), allowing the operating system installation using supported automation deployment
solutions or using images without additional drivers.
If a Hyper-V VM is provisioned by Matrix infrastructure orchestration, IO may use either a SCSI or
an IDE controller boot disk. If the Hyper-V VM is created using a VM Template, the controller will
be the same as that in the VM Template. If the VM was created with manual OS deployment or
using automated deployment solutions, the behavior is as described above for Matrix OE
visualization.
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One Hyper-V target displays when activating a logical server created on a cluster disk volume
There is a limitation in Hyper-V R1 that prevents the hypervisor from providing logical server
management with required information about a Hyper-V cluster. This causes only one target to
appear when you attempt to activate a VM logical server configured to be created on a cluster
disk volume. In Hyper-V R1, a logical server that is HA-enabled can be configured on a cluster
disk volume only.
Suggested action
Upgrade to Hyper-V R2. In Hyper-V R2, the activation of a VM logical server configured to be
created on a cluster disk or a CSV lists all Hyper-V hosts in the cluster on the target screen.

HA Hyper-V VM with an RDM disk can be activated on cluster disk owner only
When an HA Hyper-V logical server with a SAN-based storage pool entry (Disk Pass-through or
RDMdisk) is activated, only the RDM disk host owner displays as a target on which to activate the
logical server. It is not possible to enable HA for a VM with an RDM disk if the Hyper-V host that
is hosting the VM is not the owner of the RDM disk.

Some VC profile capabilities are not supported by logical server management
Importing a server with a VC profile that uses unsupported features results in the following error:
The Server Profile cannot be imported because it contains the following
capabilities unsupported by Logical Servers:

The following VC profile features are not supported by Matrix OE logical server management:

The server profile includes two or more FC connections using the same connection bay
(with the same connectionBay attribute value), which identifies a server profile created for
an HP Integrity BL860c.

EXTENDEDFC

The server profile includes more than one FCoE connection associated with the same
interconnect bay (IO bay).

EXTENDEDFCOE

The server profile includes at least one iSCSI connection.ISCSI

The server profile is associated with a Network Access Group.NAG

Applications that depend on I/O hardware paths or legacy storage DSFs are not supported with
Integrity cross-technology logical servers
HP-UX applications that have a dependency on I/O hardware paths or Legacy Storage Device
Special Files (DSFs) may fail on Integrity cross-technology logical servers. This occurs because I/O
hardware paths and Legacy Storage DSFs can change during cross-technology Move operations.
After a cross-technology logical server Move operation, Networking I/O Instance Numbers and
Storage Agile DSFs do not cause application failure.

Major issues

A new Integrity VM logical server may be assigned MAC addresses and/or server WWNs
belonging to previously unmanaged Integrity VM logical servers, resulting in duplicate MAC
addresses and/or server WWNs
If you unmanage an Integrity VM logical server, then create a new Integrity VM logical server,
MAC addresses and/or WWNs from the unmanaged logical server may be assigned to the new
logical server resulting in duplicates. If this new logical server is then activated on the same Integrity
VM host as the host containing the previously unmanaged Integrity VM logical server, an activation
error occurs due to a conflict with a duplicate MAC address and/or server WWN assigned to the
unmanaged Integrity VM logical server. Additionally, the previously unmanaged Integrity VM
logical server cannot be imported again until the newly created logical server that introduced the
duplicate MAC addresses and/or server WWNs is corrected or deleted.
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Suggested actions

• To prevent duplicate MACs and/or WWNs:

If possible, use the Delete action rather than the Unmanage action when removing an
Integrity VM logical server.

◦

◦ If possible, re-import any previously unmanaged Integrity VM logical servers.

◦ If you must unmanage an Integrity VM logical server, you may reserve its WWNs and
MAC addresses to prevent them from being reassigned by using this procedure:
1. Determine the WWNs of the unmanaged Integrity VM logical server by logging onto

the VM host and using the hpvmstatus command:
hpvmstatus –P Name_of_Unmanaged_VM | grep npiv

Sample output:
hba  avio_stor  0 1 npiv  /dev/fclp0-0x5001438002A30041,0x5001438002A30044

Make a note of the server WWNs, converting them to lsmutil format. In this example,
0x5001438002A30041 and 0x5001438002A30044 become
50:01:43:80:02:A3:00:41 and 50:01:43:80:02:A3:00:44.

2. Reserve the WWNs that belonged to the unmanaged Integrity VM logical server by
using the lsmutil –reserve –WWN WWN command (where WWN is the worldwide
name that you made note of in Step 1. Issue this command once for each of the
WWNs associated with the unmanaged Integrity VM logical server.

3. Create a placeholder logical server to prevent the MAC addresses from being
assigned to new logical servers:
a. Create a new logical server template without specifying any storage entries in

the storage configuration.
b. In the network selection page, click Add Network Entries.

NOTE: Matrix OE visualization shows the MAC addresses that were part of
the unmanaged logical server.

c. Click Next and then Finish to create the logical server template.
This Integrity VM logical server template cannot be activated because it lacks
storage entries, but the new template prevents the MAC addresses of the
unmanaged logical server from being used again.

You may now create and activate Integrity VM logical servers.

• To correct duplicate MAC and/or WWNs:
1. Delete the newly created Integrity VM logical server (after backing up its data, if

necessary).
2. Perform one of the procedures described above under To prevent duplicate MACs and/or

WWNs.
You may now create and activate Integrity VM logical servers.

Minor issues

Activating an Integrity VM logical server with three or more vCPUs may fail with an entitlement
error
If you attempt to activate an Integrity VM logical server with three or more vCPUs on an Integrity
VM Host with a 1596 Mhz or more processor speed, and the entitlement value used to create the
VM on the VM Host falls below the minimum 5% value, the activation may fail with the following
error on the VM Host:
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“Value x.x for entitlement_min is below minimum, setting to 5.0.”

Suggested action
To set the Integrity VM configuration variable GUESTMHZMIN on the Integrity VM Host to the nearest
integer value that is 5% of the host processor speed in cycles, use the following commands:
# typeset -i i j k
# i=$(hpvmstatus -sM | cut -d: -f3)
# j=i/20
# k=j*20
# if ((i>k)) ; then j=j+1 ; fi
# ch_rc -a -p GUESTMHZMIN=$j /etc/rc.config.d/hpvmconf

LUNs are not detected after activating a logical server using logical server management on an HP
Integrity Virtual Machine host
When activated directly on an Integrity VM host using Matrix OE logical server management, a
logical server fails to detect its assigned LUNs at the VM EFI prompt. The logical server does not
boot the operating system automatically, even if it is assigned with a LUN that is pre-provisioned
with an operating system.
Suggested action
View the LUN mappings, and then select the LUN in the device list that is required to boot or install
the operating system. To view the LUN mappings, perform the following steps from the Integrity
VM EFI prompt:
1. To check the configurable controllers, run the drvcfg command.

Shell> drvcfg
Configurable Components
Drv[2C]  Ctrl[29]  Lang[eng]

2. To enumerate all SCSI and FC LUNs, run drvcfg -s <drvnum> <ctrlnum>. The drvnum
and ctrlnum parameters display in the output from step 1. Press Y when prompted for
confirmation.
Shell> drvcfg -s 2C 29
Set Configuration Options
Drv[2C]  Ctrl[29]  Lang[eng]
HP AVIO Stor Driver Configuration
==================================
Warning: Enumerating all SCSI or FC LUNs increases initialization times.

Enumerate all SCSI LUNs (Y/N)? [current setting: Y]: Y

Enumerate all FC LUNs (Y/N)? [current setting: Y]: Y
Drv[2C]  Ctrl[29]  Lang[eng] - Options set.  Action Required is None

3. To reconnect drivers, refresh mapped drives and display available boot options, run the
reconnect -r and map -r commands.
Shell> reconnect -r
ReconnectController(0,0,0) : Status = Success

Shell> map -r
Device mapping table
blk0 : Acpi(PNP0A03,0)/Pci(1|0)/Fibre(WWN50001FE1501A1F39,Lun4068000000000000)
blk1 : Acpi(PNP0A03,0)/Pci(1|0)/Fibre(WWN50001FE1501A1F3D,Lun4068000000000000)

HP Matrix Operating Environment recovery management

Limitations
Matrix recovery management is not supported on a secondary CMS and all DR protected IO
services and logical servers must be on the primary CMS. This can be controlled in Matrix
infrastructure orchestration by ensuring server pools on the primary CMS are used when provisioning
IO service templates that are recoverable. When manually defining logical servers, ensure they
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reside on the primary CMS if they are to be later DR protected with Matrix recovery management.
For additional information, see the HP Matrix Operating Infrastructure Orchestration User Guide.

Required configuration for disaster recovery
Storage pool entry names must be the same at both the preferred and secondary site.
Logical servers (physical and virtual) which have been DR protected via Matrix recovery management
do not support the unmanage and subsequent import operations. Later Matrix recovery management
operations (including failover) may not succeed if a DR protected logical server is unmanaged,
edited, (for example, to modify networks or storage) and imported.

Storage Provisioning Manager
SPM runs on an x86/x64 Windows CMS. iSCSI is not supported by SPM.

Limitations

Required version of Brocade Network Advisor and HP B-Series Network Advisor
Brocade Network Advisor or HP B-Series Network Advisor 11.1.3, 11.1.4, 11.1.5, 12.1.4,
12.3.1, or 12.3.4 must be installed in order to manage Brocade-based SAN environments. No
other versions of BNA are supported.

NOTE: It is recommended to use Brocade Network Advisor and HP B-Series SAN Network
Advisor of version 12.1.4, 12.3.1, or 12.3.4.
While using the SPM automated zoning capability with HP B-series/Brocade Network Advisor
version 12.1.4, 12.3.1 or 12.3.4, you may disable Historical Data Collection to ensure BNA
provides adequate performance for SPM. To disable Historical Data Collection from Brocade
Network Advisor GUI, select Monitor→Performance→Historical Data Collection→Disable All.

NOTE: SPM performance may be negatively impacted during refresh of resources when using
BNA 11.x versions. Refer to the trouble shooting section of the HP Storage Provisioning Manager
(SPM) User Guide for alternatives to improve refresh performance.

HP B-Series Network Advisor is available from http://h18006.www1.hp.com/products/
storageworks/dc_fabricmgr/index.html. See the HP Storage Provisioning Manager (SPM) User
Guide at Enterprise Information Library for additional details.

3PAR StoreServ Storage an initiator WWN limit per controller port
Two features in SPM can be used to limit the number of initiator WWNs that may be connected
to a storage controller port. The white list capability for HP 3PAR StoreServ Storage allows a
storage administrator to control the controller ports used by SPM, thus preventing SPM from using
controller ports that are reserved for other uses. The port group feature gives a storage administrator
more detailed control over how SPM uses controller ports for all storage.
When adding ports to a storage system for which a white list is configured, if any new ports are
to be used by SPM and Matrix OE, they must be added to the white list, and the storage system
must be resynchronized in SPM.

NOTE: The white list capability can only be used for HP 3PAR StoreServ Storage.

These limitations can impact Matrix OE-created servers that use SPM to provision their storage.
Use of the SPM port group and white list capabilities are helpful to keep within 3PAR StoreServ
Storage limitations. For more information, see the HP Storage Provisioning Manager (SPM) User
Guide at Enterprise Information Library.

3PAR StoreServ Storage Zero Detect
SPM does not recognize the Zero Detect property of volumes on HP 3PAR StoreServ Storage. SPM
cannot create volumes with the Zero Detect property. SPM can import and use pre-provisioned

68 Issues and suggested actions

http://h18006.www1.hp.com/products/storageworks/dc_fabricmgr/index.html
http://h18006.www1.hp.com/products/storageworks/dc_fabricmgr/index.html
www.hp.com/go/matrixoe/docs
www.hp.com/go/matrixoe/docs


volumes with the Zero Detect property, but does not recognize the property value. SPM continues
to use volumes it has created after an administrator applies HP 3PAR Zero Detect in the HP 3PAR
Management Console, but does not recognize if a volume contains a Zero Detect property value.

3PAR StoreServ Storage Peer Motion has limited support in SPM
If Peer Motion is used on an HP 3PAR StoreServ Storage System that is imported into an SPM
catalog, a number of steps must be performed in order to ensure that SPM and Matrix OE can
properly use the storage affected by Peer Motion. For more information, see the SPM 3PAR StoreServ
Storage Peer Motion Technical White Paper at http://www.hp.com/go/matrixoe/docs.

NOTE: The online migration from EVA to 3PAR is currently not supported.

3PAR StoreServ Storage Peer Persistence is not supported in SPM
SPM does not support Peer Persistence. SPM cannot import volumes that are part of a remote copy
group, and cannot import two volumes that share the same world wide name.

Using SPM to provision RDM disks can cause VM Hosts to lose their zoning
When Matrix OE infrastructure orchestration or Matrix OE visualization with logical server
management has been used to provision a VM Host with disks provisioned using SPM (including
automated zoning), use of SPM to provision RDM disks for a VM can result in the disks for the VM
Host becoming unzoned and therefore inaccessible to the VM Host. This potentially impacts all
hosted VMs and the VM Host itself. This problem can occur with one CMS managing both VM
Hosts and VM guests, or with one CMS managing the VM Hosts and a second CMS managing
the VM guests (but no one storage volume managed by more than one CMS).

NOTE: This problem can only occur when using BNA managed switches, and SPM is configured
for automated zoning.

SPM relies on the zone name to determine whether it created the zone and thus is responsible for
cleaning it up. When a VM Host is initially created using SPM provisioned disks, SPM will create
zones for the VM Host initiators. Later, when using SPM to provision RDM storage for VMs, these
same zones are used. In the previous scenario, when the VM RDM disks are removed, SPM may
not realize that the zone is still being used by the VM Host itself and remove the zone when
removing the storage.
Suggested action
To prevent this from occurring, manually change the zone name for the VM Host to no longer
include the prefix SPM_ in the name. Do this prior to using SPM to provision RDM storage for VMs.

Minor issues

Windows 2008 may fail on servers with Emulex LPe1205 HBA with multipath
When an attempt is made to deploy Windows 2008 on a server that contains Emulex LPe1205
HBA, the deployment may fail if more than one storage controller port is zoned for visibility. The
server fails to boot from SAN and continuously reboots.
Suggested action
Since SPM automated zoning provides visibility to all controller ports on the given fabric (unless
port group zoning is used to restrict this), it is necessary to set SPM for manual zoning on the given
fabric/network.
1. Create an XML file for the unmanaged network and set the state to Zoned.
2. From SPM, choose Edit Network and check Allow External Processing.
3. Contact the storage administrator to manually zone each initiator WWN to a single controller

port. The controller port used in the storage pool entry for the volume also needs to be zoned.
4. Edit the SPM XML file representing the fabric/network to include the zone set(s).
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After the next refresh or a resynchronization of the network, the Matrix workflow can be resumed.
For more information, see the HP Storage Provisioning Manager User Guide and the Faster storage
provisioning in the HP Matrix Operating Environment: Use of the HP Storage Provisioning Manager
storage catalog with controlled storage operations available at http://www.hp.com/go/matrixoe/
docs.

Managed node installation

Limitations

Multipath I/O and Emulex FC HBA or Emulex FlexFabric Converged Network Adapter is not
supported on Windows Server 2008, Windows Server 2008 R2, and Windows 2012

Using multipath I/O during OS installation is not supported with an Emulex FC HBA or an Emulex
FlexFabric Converged Network Adapter on any CloudSystem Matrix-supported server on Windows
Server 2008, Windows Server 2008 R2, and Windows 2012.
The following suggested action enables you to install the OS single-path and then modify the
storage definitions to create multiple-path access to the boot volume. After a successful OS
installation, these instructions define an additional physical path to the boot volume by:

• Modifying the storage definition to add an additional server HBA definition (port).

• Modifying the boot volume definition to add a second physical ‘path’ to its definition.
Suggested action 1
If you are creating a template using Matrix OE infrastructure orchestration designer, select Redundant
SAN paths to disk when configuring the boot volume. Matrix infrastructure orchestration executes
steps to work around this issue by ensuring that the OS is single-path while the OS is being
provisioned, and then modifies the storage definitions to create multipath access to the boot volume
when OS provisioning is complete.
Suggested action 2
If you are defining a storage pool entry in Matrix OE visualization using the Manage Storage Pool
interface:
1. Define the storage pool entry. Add multiple ports and mark all non-boot disks as redundant.

Keep the boot volume as a single path.
2. Assign the storage pool entry to a logical server.
3. Activate the logical server.
4. Provision the OS, and install the multipath IO drivers as appropriate.
5. Deactivate the logical server.
6. Modify the storage pool entry to make the boot volume redundant.
7. Reactivate the logical server.

Other issues and suggested actions

Minor issues

RHEL 7.1 OS deployment may fail on ProLiant servers configured with SAN multipath
For RHEL 7.5 deployments in a multi-path environment, refer to the deployment software
documentation for how to enable multi-path.

NOTE: If Storage Provisioning Manager is used to zone the LUN and zones to multiple target
ports on the storage solution, then multipath must be configured for any RHEL 5.9 deployment with
the LUN provisioned by SPM.
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HP SIM security certificate is not imported
A problem occurs when an Insight Remote Support Advanced installation is supporting an HP-UX
Mission Critical contract and the HP SIM security certificate is 2048 bits. System Management
Homepage (SMH) does not automatically import the HP SIM 2048–bit certificate causing
communication with HP-UX Advanced Configuration Collections to fail. In HP SIM 7.2, the security
certificate is 2048 bits by default, but this issue also occurs if a previous HP SIM 7.x setup changed
the certificate to 2048 bits.
Suggested action
Upgrade to the latest HP-UX SMH version from https://h20392.www2.hp.com/portal/swdepot/
displayProductInfo.do?productNumber=SysMgmtWeb.

Managing an Hyper-V (or any MSCS) cluster when an alias is assigned by DHCP
In Windows Server 2008 Failover Clusters, if the cluster alias is assigned using DHCP, the cluster
alias PTR (reverse lookup) record in DNS is incorrect, causing the cluster to be discovered incorrectly
in HP SIM.
To correct this problem, delete the cluster objects from HP SIM, follow the steps in the Microsoft
Knowledge Base article at http://support.microsoft.com/kb/969049 to modify the cluster DNS
behavior, and then rediscover the cluster in HP SIM.

VM kernel port name used for management traffic must be “Management Network”

• When trying to activate a logical server, the ESXi/vSphere hosts appear as Rejected Target
hosts with an error that the hosts are not part of vCenter, or that Insight Control virtual machine
management is unable to get vCenter information for the VM host.

• The association between the host and vCenter does not appear in HP SIM.
Suggested action
Modify the Network Label of the VMKernel port used for management traffic to “Management
Network”:
1. Log into vCenter using the vCenter client.
2. Select the Hosts and Clusters view from the View→Inventory menu.
3. Select the ESXi server from the tree in the left pane.
4. Select the Configuration tab in the right pane.
5. In the Hardware section, select Networking.
6. Click Properties for the Virtual Switch where the VMKernel port used for management traffic

is located. If there are multiple VMKernel ports located on multiple virtual switches and
configured for management traffic, select the switch that has the VMKernel port with the IP
that is registered with Insight Control virtual machine management, or that will be used for
registration with Insight Control virtual machine management.

7. In the virtual switch properties pop-up window, select the service console port, and then click
Edit.

8. Change the Network Label to “Management Network,” and click OK. Close the virtual switch
properties pop-up window.

It can take up to five minutes for the cache to refresh and the API to report the ESXi/vSphere host.
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4 Support and other resources
Contacting HP

Information to collect before contacting HP
Be sure to have the following information available before you contact HP:

• HP CloudSystem Matrix Starter Kit or Expansion Kit HP BladeSystem c7000 Platinum Enclosure
serial number and/or SAID if applicable

• Software product name

• Hardware product model number

• Operating system type and version

• Applicable error message

• Third-party hardware or software

• Technical support registration number (if applicable)

IMPORTANT: Be sure to mention that this is a HP CloudSystem Matrix configuration when you
call for support. Each HP CloudSystem Matrix Starter Kit or Expansion Kit HP BladeSystem c7000
Platinum Enclosure serial number identifies it as a HP CloudSystem Matrix installation.

How to contact HP
Use the following methods to contact HP technical support:

• See the Contact HP Worldwide website for contact options:
http://www.hp.com/go/assistance

• Use the Contact hp link on the HP Support Center website:
http://www.hp.com/go/hpsc

• In the United States, call 1-800-334-5144 to contact HP by telephone. This service is available
24 hours a day, 7 days a week. For continuous quality improvement, conversations might be
recorded or monitored.

Registering for software technical support and update service
HP CloudSystem Matrix includes as standard, three or one year of 24 x 7 HP Software Technical
Support and Update Service and 24 x 7 four hour response HP Hardware Support Service. This
service provides access to HP technical resources for assistance in resolving software implementation
or operations problems.
The service also provides access to software updates and reference manuals in electronic form as
they are made available from HP. Customers who purchase an electronic license are eligible for
electronic updates.
With this service, Insight Management software customers benefit from expedited problem resolution
as well as proactive notification and delivery of software updates. For more information about this
service, see the following website:
http://www.hp.com/services/insight
Registration for this service takes place following online redemption of the license certificate.
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How to use your software technical support and update service
As HP releases updates to software, the latest versions of the software and documentation are
made available to you. The Software Updates and Licensing portal gives you access to software,
documentation and license updates for products on your HP software support agreement.
You can access this portal from the HP Support Center:
http://www.hp.com/go/hpsc
After creating your profile and linking your support agreements to your profile, see the Software
Updates and Licensing portal at http://www.hp.com/go/hpsoftwareupdatesupport to obtain
software, documentation, and license updates.

Warranty information
HP will replace defective delivery media for a period of 90 days from the date of purchase. This
warranty applies to all Insight Management software products.

HP authorized resellers
For the name of the nearest HP authorized reseller, see the following sources:

• In the United States, see the HP U.S. service locator web site:
http://www.hp.com/service_locator

• In other locations, see the Contact HP worldwide web site:
http://welcome.hp.com/country/us/en/wwcontact.html

Customer advisories
A customer advisory is a concise communication clearly identifying specific issues and the effective
resolution for selected products. If you are experiencing difficulty, there might be a customer
advisory that can help you. You can receive proactive customized email messages that provide
customer advisories as well as drivers, software patches, product change notifications, patches,
security bulletins, and more. Sign up for HP Subscriber’s Choice at the following website:
http://www.hp.com/go/myadvisory

Related information
The latest versions of manuals and white papers for HP CloudSystem Matrix and related products
can be downloaded from the web at www.hp.com/go/assistance.
HP CloudSystem Matrix documentation refers to Matrix Operating Environment documents, HP
Server Automation (SA), and HP Cloud Service Automation (CSA).
For Matrix Operating Environment documents, see the Insight Management documentation: http://
www.hp.com/go/matrixoe/docs.
For HP Server Automation (SA) and HP Cloud Service Automation (CSA), search the SSO portal
to retrieve relevant documentation:
1. Navigate to the SSO portal (http://support.openview.hp.com/selfsolve/manuals).
2. Login to HP Passport, if necessary. If you do not already have an HP Passport account, you

will need to create one.
3. In the Product menu, select Server Automation or Cloud Service Automation.
4. In the Product version menu, select the most current version.
5. In the Operating system menu, select the relevant operating system.
6. Click Search.
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Typographic conventions
This document uses the following typographical conventions:
Book title The title of a book. On the web, this can be a hyperlink to the

book itself.
Command A command name or command phrase, for example ls -a.
Filename The name of a file or the path to a file location.
Computer output Information displayed by the computer.
Ctrl-x A key sequence that indicates you must hold down the keyboard

key labeled Ctrl while you press the letter x.
ENVIRONMENT VARIABLE The name of an environment variable, for example, PATH.
Key The name of a keyboard key. Return and Enter both refer to the

same key.
Term A term or phrase that is defined in the body text of the document,

not in a glossary.
User input Indicates commands and text that you type exactly as shown.
<Replaceable> The name of a placeholder that you replace with an actual value.
[ ] In command syntax statements, these characters enclose optional

content.
{ } In command syntax statements, these characters enclose required

content.
| The character that separates items in a linear list of choices.
... Indicates that the preceding element can be repeated one or more

times.
WARNING An alert that calls attention to important information that, if not

understood or followed, results in personal injury.
CAUTION An alert that calls attention to important information that, if not

understood or followed, results in data loss, data corruption, or
damage to hardware or software.

IMPORTANT An alert that calls attention to essential information.
NOTE An alert that contains additional or supplementary information.
TIP An alert that provides helpful information.
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5 Documentation feedback
HP is committed to providing documentation that meets your needs. To help us improve the
documentation, send any errors, suggestions, or comments to Documentation Feedback
(docsfeedback@hp.com). Include the document title and part number, version number, or the URL
when submitting your feedback.
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